Help - Search - Members - Calendar
Full Version: Using Mkdir In /usr/local
Linuxhelp > Support > Technical Support
00420
I am very new to Linux. I've been trying to install Adobe Acrobat Reader today, but when I run the installation script it says "mkdir: cannot create directory `Acrobat5': Permission denied".

So, then I tried to create the directory myself (instead of having the script do it). But, I got the same message. Then I tried doing it from my root user, and I still got the same message.

I using the chmod command so that permission would stop being denied, but when I do that it says "chmod: changing permissions of `local': Operation not permitted"

What am I doing wrong?
Corey
Linux runs on permissions. Regular users are not permitted to create files anywhere but there home directory and /tmp directory (maybe others, depending on installation). In order for you to install acrobat into /usr/local , you need to be root. There are two ways to do this, either A) type "su" at the command prompt and enter your root password, this will log you in as root and allow you to install anywhere in the system. Or cool.gif install the sudo package and read the documentation. A quick fix would be just to "su" and install the package, and then immediatly log out again.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.