Help - Search - Members - Calendar
Full Version: Need help with a netgear wna3100 wireless usb adapter
Linuxhelp > Support > Hardware Support
I am triple booting with Win XP Pro, Win 7 Ultimate and Ubuntu 11.10, everything is fine except I have no internet in Ubuntu while I am using the Netgear WNA3100 Wireless USB adapter.
I have the "ndiswrapper" tarball on my desktop and in a folder located in my home/wireless driver folder (a folder I created), also in this folder is the extracted files from the tarball and the 4 broadcom .inf and .sys files for this adapter, 32 bit and 64 bit I believe.

I cannot get ndiswrapper to install at all. I read somewhere to install "windows wireless driver program" (I am assuming this meant ndiswrapper) then point the program at the .inf file, (in my case the 64 bit version) and it should work.

But I cannot find an installer in ndiswrapper, what am I doing wrong.

I had exactly the same problem with my wna3100 and ubuntu 11.04 After two weeks of trying all suggestions I could find on the net, I succeeded. I hardly know anything about linux and found it quite simple. You just need the right driver.

Do the following step by step:

-plug in the wna3100

-open the terminal and type: lsusb

-hit enter, you should see something like this: Bus 001 Device 002: ID 0846:9020 NetGear, Inc.

if the answer is yes go on with the following

create a folder somewhere you could find it easily (name it wifi driver or so)

download the driver from here: (just copy the url, paste it in your web browser and hit enter if the link doesn't work)

-You will get a box that ask to open or save the driver file

-open it with whatever program you use to unzip (or save it somewhere and unzip it from there)

-unzip it to the folder you created in the first step

-right click both .inf files, go to tab 'rights' and click on the make file executable box (mine is in dutch so I don't know if the translation is right)

close that window

do the same for the .sys files
now open the windows wireless driver program (download it from ubuntu software center if you don't have it)

browse the .inf file with that program and click install.
never erase the folder where the .inf and .sys files are found
pull out the wna3100
reboot your computer
plug in the wna3100, when it stops blinking open the network manager.
You should be able to see your wireless network.
if yes, then jump up like me and shout yeehaah (or something alike)
if not, i feel really sorry for you, but somehow this worked for me and my ubuntu 11.04

I also tried this:

clay@clay-comp2:~$ sudo apt-get install ndiswrapper-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ndiswrapper-common

As you can see this didn't work.

Other things I have tried:

clay@clay-comp2:~$ sudo lshw -c network
[sudo] password for clay:

PCI (sysfs) shows or does nothing

clay@clay-comp2:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

Here is your list of items you wanted, I couldn't paste them here, the forum would not let me, said it was too long.
Paste from Clayman1000x at Fri, 23 Dec 2011 08:29:51 +0100

I could really use some help putting a package together.
Try this:
QUOTE (michaelk @ Dec 23 2011, 03:00 PM) *

I tried this earlier today, I downloaded all 3 files for 11.04, to my flash drive, I am assuming they should work on 11.10 also. I cannot get them to install, there is nothing to doubleclick and install, a few things I clicked on opened a terminal and it closed right away, I have no idea what it did at all. I am really trying to learn here but I am getting frustrated with this. All I can do is download from xp, reboot into ubuntu then try it but I don't understand what I am doing. I even have a tutorial video to help but I just can't seem to make heads or tails out of these zip files. I don't know tha basic commands to check if what i am doing is working. So frustrated, sometimes I want to give up but I won't let myself. Sorry bout the rant but I am off to ubuntu to try this again.
By the way, what is a .deb file, a zip file?
This is how I laid out my home folder:
Home/wna3100/Broadcom_drivers/....4 driver files, 2 .inf and .sys (bcmn43xx64 and 32)
......................./ndisgtk/....2 files, Debian and usr
...................... /ndiswrapper-157rc1/....2 files, Debian and usr
......................./ndiswrapper-utils-1.9/....3 files, Debian and sbin and usr

There are also other folders in my home folder as you know but these are the ones that matter now.
A deb file is a compressed file but it contains special information about how to install the application. These are known as packages. deb files are install packages for debian but Ubuntu is a derivative of Ubuntu. dpkg is the installer application program.
QUOTE (michaelk @ Dec 23 2011, 10:39 PM) *
A deb file is a compressed file but it contains special information about how to install the application. These are known as packages. deb files are install packages for debian but Ubuntu is a derivative of Ubuntu. dpkg is the installer application program.

Thanks for the info, I think I finally have ndiswrapper installed, here is the link:

Does it look installed to you? Problem now is how to use it to load the broadcom drivers, and I still can't get the ndisgtk (gui I think) and the ndiswrapper-utils-1.9 to install, below is the output from the utility.

clay@clay-comp2:~$ cd /home/clay/wna3100_driver/
clay@clay-comp2:~/wna3100_driver$ ls
Broadcom_drivers ndisgtk ndiswrapper-1.57rc1 ndiswrapper-utils-1.9
clay@clay-comp2:~/wna3100_driver$ cd ndiswrapper-utils-1.9
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9$ ls
DEBIAN sbin usr
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9$ cd usr
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9/usr$ ls
sbin share
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9/usr$ cd sbin
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9/usr/sbin$ ls
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9/usr/sbin$ install ndiswrapper-1.9
install: missing destination file operand after `ndiswrapper-1.9'
Try `install --help' for more information.
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9/usr/sbin$ ls
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9/usr/sbin$ cd ndiswrapper
bash: cd: ndiswrapper: No such file or directory
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9/usr/sbin$ ls
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9/usr/sbin$ cd ~/wna3100_driver/ndiswrapper-utils-1.9/usr/
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9/usr$ cd share
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9/usr/share$ ls
doc man
clay@clay-comp2:~/wna3100_driver/ndiswrapper-utils-1.9/usr/share$ cd ~/wna3100_driver/Broadcom_drivers
clay@clay-comp2:~/wna3100_driver/Broadcom_drivers$ ls
bcmn43xx32.inf bcmn43xx32.sys bcmn43xx64.inf bcmn43xx64.sys

I am learning some, very little but it is coming. A lot of trial and error and hours working on it. All of these programs came from that link you gave me.
Please let me know what you think.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.