Help - Search - Members - Calendar
Full Version: Samba Security Question
Linuxhelp > Support > Technical Support
wbullard
I am new to Linux and have added a Red Hat 9 machine to a Windows 2000 domain. Samba is working as I can access shares on my Windows machines and Windows can access shares on the Red Hat box. I have password encryption enabled but when I try to connect to a Windows machine from Red Hat, it says "You must login to access smb//:"WindowsMachine". Your password will be transmitted unencrypted." In the above scenario, it accepts the password and lets me connect to the share, but I don't want clear text passwords sent across the wire. (It does not prompt me for a password when I connect to the Red Hat box from a Windows 2000 machine). How do I force Linux to encrypt the passwords that it sends to Windows?

I have created the same user account in both the Windows Domain and and on the Red Hat machine. I also added that account as a Samba user. The Windows password, Linux password and the Samba password, for that user account, are the same. The Samba server is configured to use Domain Authentication with my Windows 2000 domain controller as the Authentication Server. Encrypt passwords is set to Yes. It was configured using the Gnome graphical utility. I have also created a machine account for the Red Hat box in the Windows 2000 domain and joined the Red Hat Machine to the domain with the following command: smbpasswd -r PDC_NAME -j DOMAIN_NAME

I am just learning Linux, so any help would be appreciated.

Thank you in advance.

WRBullard
chrisw
There is a guide on this site about setting up samba...and mentions about the encrypted password
stuff between linux and windows....take a look at that....
bardsley
I am having a similiar problem which is compounded by the fact that it wont remember my password. I have to login for every file I get and each time I access a folder I get a login dialog to open it AND a login dialog for the subsequent listings of the folder.

This is when I am using nautilus and smb:// in the address bar in newly installed red hat 9. I also have the plain text password problem described above and have read 4 setup guides and the ENTIRE (very comprhensive I might add) man page.

sad.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.