Help - Search - Members - Calendar
Full Version: Cr-rw No Longer Will Mount
Linuxhelp > Support > Technical Support
rayber2000
After the last kernal update etc/fstab failes and my CD-ROM will no longer mount.
I am running Redhat 8.0 with the latest kernal and updates.
I have the CD-RW and a CD-ROM (the CD-ROM mounts fine)
The CD-RW was working and appears to have no mechanical issues.
The system lists the CD-RW Aopen CRW 1232 which is the same as it always has been.

I have made no changes to etc/fstab and everything appears to be correct there.

Any help would be appreciated
Corey
I'm not sure of redhat's mount structure, i'm guessing it's /mnt/cdrom and /mnt/cdrom1 ? Anyways, if your CDR-RW is on the slave on your secondary IDE, then try mounting it with:

QUOTE
mount -t iso9660 /dev/hdd /mnt/cdrom1


/dev/hdd = the actual device for the cd-rw, /dev/cdrom1 is just a symlink that may be pointing wrong.
rayber2000
Thank you for posting a reply.
As root I typed mount -t iso9660 /dev/hdd /mnt/cdrom1 and got:
mount: mount point /mnt/cdrom1 does not exist

Any other suggestions?

Thank you.
Corey
All that error means is that /mnt/cdrom1 wasn't the proper mount point. Go into your /mnt directory and do a "ls" to see what other directories are there. Most distributions with two cdroms have entries for "floppy", "cdrom", and "cdrom1". If cdrom1 doesn't exist, you can just make it with "mkdir /mnt/cdrom1" then try to mount it again with the above command.

And, just for any future reference, check out the man page for mount with "man mount" there's a lot of useful stuff in there.
rayber2000
Thank you so much for your help. I have tried everything you have suggested and still can't get it to work.
I read man mount and have researched this online and in other forums and still can't find an answer.
After I followed your last set of instructions (you were right about cdrom1 not being in /mnt, but it used to be) I got the following:

mount: wrong fs type, bad option, bad superblock on /dev/scd0,
or too many mounted file systems
I am wondering if this issue lies with something other than mounting?

I still get the main error at boot:
etc/fstab failed cannot stat dev/cdrom1

This is my etc/fstab:
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdb2 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,kudzu,ro 0 0
/dev/sda /mnt/usbbus auto noauto,user 0 0

It worked like a champ untill a week ago. If this is a mount issue I'm missing something and further help would be very much appreciated. I am usually able to fix things like this on my own by typing in the error in a google search but this time I am really stuck. Thanks again for you help thus far.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.