Help - Search - Members - Calendar
Full Version: screwed up fstab, now can't edit it
Linuxhelp > Support > Technical Support
manuginobili
Hi I'm a newbie. Basically, I installed Fedora 10 on my aspire one, I chose to enable the encryption option, and lately I've been playing with fire editing things I don't know much about, fstab to be precise. Well, I wanted to mount my /home directory in another partition but I screwed up, so now I can only start the computer, enter the password and get an error message that says the filesystem is corrupted or something like that.
In the shell I tried to edit the /etc/fstab and eliminate the line that messed all up, but it says it is read only so I can't save. Tried sudo and it says you have to be in tty to do it. Please, help me to solve the problem. Thanks in advance.
Regards
manuginobili
Ok, after more than an hour trying things I found in google if you type in repair filesystem
mount -w -o remount /
then you can edit the fstab and save it.
Still don't understand why I couldn't save the file before, it was mounted rw
Anyway thanks
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.