Help - Search - Members - Calendar
Full Version: Scanner help needed
Linuxhelp > Support > Hardware Support
Beckfield
Hi all,

I have an Epson Perfection 2450 scanner.

My system:
Kubuntu 8.04, and the scanner is connected by FireWire.
XSane and xsane-common 0.995-1ubuntu1
libsane 1.0.19-1ubuntu3

I'm having a difficult time getting SANE to recognize the scanner. When I run XSane as a regular user, it cannot detect the scanner. If I run it as root, it detects the scanner, but misidentifies it as an Epson GT-9700. If I accept this and go on to the UI, and try to Acquire Preview, it reports "Failed to start scanner: Error during device I/O. I have tried connecting the scanner via USB as well, but that also fails. I don't care which interface I use, so if one is simpler to get working, I'm fine either way.

I would appreciate any advice. If there is any other system information I can provide that will help, please let me know what it is, and how to get it. I'm very experienced with DOS and Windows, but my Linux experience is not very deep; I'm not much beyond a rookie with Linux. I don't mind getting into configuration files, as long as I know where to find them and exactly what to do with them.

Thanks for any help.

Oh, I should mention that the scanner works under Windows, so I know the scanner is probably not broken.

PS - I've been trying to add the output of dmesg to this, but it keeps complaining that the message is too long. What is the size limit? Can I attach a text file?
michaelk
Could not find much information. There are some sane epson drivers but according to the website it is no longer being supported. The site just says to use
whatever comes with the distribution.

http://www.sane-project.org/lists/sane-mfgs-cvs.html#Z-EPSON
http://www.sane-project.org/man/sane-epson.5.html
Beckfield
QUOTE (michaelk @ Dec 26 2008, 07:04 AM) *
Could not find much information. There are some sane epson drivers but according to the website it is no longer being supported. The site just says to use
whatever comes with the distribution.

http://www.sane-project.org/lists/sane-mfgs-cvs.html#Z-EPSON
http://www.sane-project.org/man/sane-epson.5.html



Thanks, yes, I've been to those sites. As far as I can tell, I've done everything they say. There was never a mention about what to do if the scanner can only be detected if running as root, though. Do you have any ideas on that?

Beckfield
Someone in another forum provided the following link, which led me straight to the problem. I thought I should share it here, in case anyone else encounters the same problem.

I went through the steps described (some had already been done, but it never hurts to doublecheck), and found the problem. In short, there was an entry in epkowa.conf that was commented out; a legacy problem from the previous version of Ubuntu, apparently. I followed the steps to correct this, and my scanner is now working. It takes a long time for SANE to detect the device, and for some reason it detects and lists the scanner twice, but at least I am scanning.

Fixing Epson scanners in Ubuntu 8.10 Intrepid Linux

I hope it helps someone else.
michaelk
Well done
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.