Help - Search - Members - Calendar
Full Version: Pppoe Internet Connection Disfunctional
Linuxhelp > Support > Technical Support
grasshopper
Hello,

The other day, I got my first linux (debian "woody") system walking. yay!
However, now I'm trying to get my pppoE bell sympatico internet connection (DSL or ADSL ... not sure which, how do you tell?) to work so I can download the rest of the debian packages I need to finish setting things up.

I've been following "Joey's PPPoE (ADSL) Guide" on this web site, but I seem to have come to an "impass". I've made an effort to read the great documents related to internet connectivity on this site, but it seems I'm still missing something.

I receive the following error message:

pppd: The remote system is required to authenticate itself
pppd: but I couldn't find any suitable secret (password) for it to use to do so.
pppd: (None of the available passwords would let it use an IP address.)

I've checked the user name and password for this internet connection and they are correctly typed in.
Other than that, I really don't know where to poke around and what to change in order to diagnose and solve this problem.

Also, please note that I very recently got linux installed and am a beginner.
Perhaps there is something very simple I am missing?

Two other things I noticed:
- I can't ping the other computer (running windows) on my small home network. Do I need to tell linux who this computer is somehow, even just to ping?
- I can't run "pppd" as a normal user, it seems that I must be logged in as root to do this. Does this mean the ordinary user can't establish an internet connection? How could I change this?

Note: I am attempting to connect with PAP.

Perhaps someone could please offer some suggestions? It would be greatly appreciated.
Joey
Hi,

Can you describe your network setup for me. What machine is the gateway, linux or windows?

What software are you using to connect? You should be using the one from http://www.roaringpenguin.com, it's fairly simple to install and get working.

What do you have in your /etc/ppp/pap-secrets file? It should be your username and password. I think your username has to include the @sympatico.ca part. ie :

b153sfg3463@sympatico.ca * yourpassword
Corey
PPPoe is the devil. Long live dhcp


Anyways, Joey is correct with the username thing, that got me plenty of times when trying to set up an internet connection on my girlfriend's linux box. She is running Debian woody as well.

Did you run the pppoeconf to setup the connection? I found this a quick and easy way to setup the pppoe connection.
chrisw
good thing i got a static ip for my dsl....
none of that pppoe config stuff
grasshopper
Ok, thanks for the suggestions so far. I've tried a few things and here are the results:

downloaded and installed the rp-pppoe software. Ran it with "adsl-start" and it spewed out the following message:

...........TIMED OUT
/usr/sbin/adsl-start: line 191: 2840 Terminated
$CONNECT "$@" >/DEV/NULL 2>&1

Ok, then I opened the "adsl-start" file in the vi editor, showing the line numbers and the code around line 191 seems to detect a timeout condition, kill the adsl-connect process and quit.

Two further runs of adsl-start yielded:

...........TIMED OUT
/usr/sbin/adsl-start: line 191: 3099 Terminated
$CONNECT "$@" >/DEV/NULL 2>&1

.registered device ppp1
...........TIMED OUT
/usr/sbin/adsl-start: line 191: 3319 Terminated
$CONNECT "$@" >/DEV/NULL 2>&1


*********

Another thing I tried before the above was running pppoeconf
Results:

-----
Scanning device
Looking for pppoE Access Concentrator on eth0

NOT CONNECTED
Sorry, I scanned 1 interface(s), but the Access Concentrator of your provider did not respond. Please check your network and modem cables. Another reason for the scan failure may also be another running pppoe process which controls the modem.
-----

Cables seem fine.

Description of network:
1 computer with linux (debian woody) installed
1 computer with virus98 ... I mean win98 ... for non-linux users ... to be hopefully converted if this internet connection starts working soon ...
1 switching hub
1 adsl high speed internet connection box (accepts RJ-45 ethernet connector and phone line cord)
CAT-5 Ethernet cable for connections between computers-and-switch and modem-and-switch.

Note: Tests showed I have no problems connecting to my ISP (Bell-Sympatico) with the windows based computer...

Please help ...
teeemoy
we basically have the same setup....i was able to connect using pppoeconf myself, no problems whatsoever....now my problem is sharing the connection with my network....but that's another story....

in your case, i think it has something to do with your aDSL modem/router...try making sure that your other PC is connected to the net using that modem....because when that error happened to me, my sis connected to the net without telling me....took me a while to find out....i was pissed....and yeah...make sure your IP addy is xxx.xxx.xxx.1...that's if you plan to be the gateway...

peace.... biggrin.gif
michaelk
I assume this is a plain modem with no router functions?

IMHO if you want to share files between the two PCs I suggest using a firewall/router. This will isolate your local network from the internet.

Did you run adsl-setup to configure pppoe?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.