Hi Folks,

I have a ##@@$%$ problem with the authentication (.htaccess/mod_auth_mysql)

I tryed several config:
http://www.diegonet.com/support/mod_auth_mysql.shtml
http://www.linuxhelp.net/guides/htaccessmysql/

so now let me explain.
The first link is great when you have a debian. I tried the config on my debian and it was working perfectly.
However I have to do the same configuration but on a redhat and this is where the problem begin.
the .htaccess are not the same and the httpd.conf is different. (I tried my debian conf and nothing was working).

I am doing an authentication based on login/pass/group
my path is /var/www/
above the www I have a rep call galleries and inside I have rep1, rep2 and rep3 which are the 3 directory that are protected with 3 different .htaccess file. The only difference between this 3 .htaccess is the group required.

these are my config file:
.htaccess:
-------------
AuthName sweetmuscle.com
AuthType Basic
AuthGroupFile /dev/null
AuthMySQLNoPasswd off
AuthMySQLHost localhost
AuthMySQLDB sweetmuscleDB
AuthMySQLUserTable user
AuthMySQLUser webmaster
AuthMySQLPassword my!passwd#
AuthMySQLNameField user_login
AuthMySQLPasswordField user_passwd
AuthMySQLGroupTable user
AuthMySQLGroupField user_sub_type
AuthMySQLCryptedPasswords off
AuthMySQLAuthoritative on
require group cp

httpd.conf:
--------------
<Directory /usr/share/galleries/rep1>
Options Indexes FollowSymLinks
AllowOverride AuthConfig
order allow,deny
allow from all
</Directory>

This is what I do when I try to access the index.html inside one of the rep (rep1, rep2, rep3)
http://mylogin:md5_of_the_passwd@www.myweb...rep1/index.html
the field user_passwd has md5 password that is why I have: AuthMySQLCryptedPasswords off

so my error is the following:
The page cannot be displayed blablabla....

and when I check the error_log of my apache I have this error:
[Thu May 8 18:33:53 2003] [notice] child pid 8506 exit signal Segmentation fault (11)

So if someone has a idea :-)