Help - Search - Members - Calendar
Full Version: Password
Linuxhelp > Support > Technical Support
EdwardC
Hello,

Im totally clueless when it comes to Linux and my old line manager quit a while ago where I work, he had set up a intranet/helpdesk server that ran on Linux (Unsure what type of linux, all I know is it has a lilo boot thing and is 2.4.something version). To cut the story short we had a power cut and when we tried to boot up the server it asked for a login, which me or the other technician don't know, the old line manager who hated the school won't tell us the details so we cant get into it, so we need to reset the root password.

I did some research and found some guides that said to boot up into single user mode but that required a password to log into still. Also tried other ones that said to boot with Linux =/bin/bash at the lilo boot menu and then try passwd command, but then it said "Cannot lock the password file; try again later". Then I read some guides that said to remount the drives (got a little confusing here for me) with a command like mount -o remount,rw or something like that, but once I entered that and then tried typing in passwd, nothing happened at all, and I stopped trying at that point..

Is there something im doing wrong or is it not possible to reset the password if thats the case we will just reinstall with something we know.


Thanks,

Ed
michaelk
I assume this is a legit request and not sure why single mode is not working. If single user mode fails then I would say you should try using a lived CD such as knoppix. You will then need to mount the root partition and then edit the desired files.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.