Help - Search - Members - Calendar
Full Version: HP laptop won't boot live linux
Linuxhelp > Support > Technical Support
myris
Hello,

I've been trying to start learning Linux. I was trying to start by testing the various live versions of Linux. I've tried ubuntu, linuxmint and debian live, but none of the versions seemes to want to boot. Every attempt ended with a black screen after i have been watching a lot of loading text pass by on the screen. I haven't been able to get into the actual linux deskop yet. So I'm a bit worried if it is my computer that is messing up the boot or what?

What more information do you need to help me, let me know and I will help you help me.

Thanks!
arochester
Did you create the disks yourself? A common mistake among newcomers is to simply copy the iso onto a disk, whereas they need to "burn an iso" - that is create a special bootable disk.

What are the system specs of your computer? There might be a hardware incompatibility. Does the computer have a make and model? What is the make and model of your video card? How much RAM do you have?

"Every attempt ended with a black screen after i have been watching a lot of loading text pass by on the screen". Have you changed the boot order so that it boots from the CD-Rom first? Is there another OS on the machine?
myris
My laptop is a hp pavillion dv6240eu with

AMD Athlon X2 64 bit
1GB RAM
GPU graphics card

It does boot into the linux disc and all, and I do burn it as an ISO. And linux does start to load, but when it has loaded for such and such long time it just won't start, it just goes black and stops. I have win vista x64 installed. But I am just trying to use a live linux to check it out. My plan was to install it in a while. I just got worried that I couldn't install it later as it even won't live boot now?

Anyone, help?
arochester
Have you tried different booting? Try acpi=off. (I think when booting starts you press F6 to change)
DS2K3
Let's start with the basics:
- Boot like you have been doing
- Press Ctrl+Alt+F1
- Do you see text? If yes, then there is a problem with the GUI (the X server)

Try your disks in another computer (preferably a desktop) - It is unlikely that three disks would all be bad, but it is possible. I would also recommend that you try a Fedora Live CD - Debian is quite "power-user" and so doesn't do as much for you, but Fedora *might* manage to configure itself around the problem (Ubunutu normally gets things right though).

The problem is that laptops tend to have odd hardware that is not well supported under Linux - As previously mentioned, you may have some luck by adding "acpi=off" and/or "noapic" to the kernel boot options - But i'm not sure how you modify them for Ubuntu or Debian off the top of my head. There is normally an option to add or pass "kernel parameters" on the boot screen though, try adding the "acpi=off noapic" and see what happens (yeh, the acpi and apic are spelt differently smile.gif

D
myris
Hi guys,

Thanks for all the help. I tried Fedora last night, before I even saw you post, and it did work! smile.gif That's nice, now I can start to learn some Linux. Thanks again!
DS2K3
No problem

*closing*

D
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.