I'm having a bit of an issue with Opensuse 10.3 that was never a bother for me in 10.2

When I plug in a USB device (any type - camera, drive etc) it is not detected.
If I plug in the device with the computer turned off then boot up it is loaded without problem and available for use.

In 10.2 I didn't have any problem like this - I just plugged in the device and it was detected and a window popped up asking me what I want to do.

Here's what I have tried.
Reinstall, downgrade and upgrade HAL & D-BUS
Tried installing IVman
Downgrade linux kernel to that which came with the 10.3 CD

none of these have made the slightest difference.

Checked out my hardware by running a livecd of pclos. Plugging in USB devices are detected without problem.

If I run fdisk -l with the devices plugged in it shows absolutely nothing has been detected - so they are not even available for a forced mount.

I'd really appreciate some help on getting this issue solved - it is proving a real head scratcher.

Running 10.3 with KDE 3.5.7 32 bit