Help - Search - Members - Calendar
Full Version: Unable to view my Servers (Linux 7) www Pages
Linuxhelp > Support > Technical Support
mhauth
This is a strange problem for me at least.

OS: Fedora 7
IP:192.168.0.25
Router - Linksys WRTG54G
Dydns.org forwarding - evolutionofgolf.selfip.com

I can connect from my desktop via ssh and run commands but from the same computer I can't go to www.evolutionofgolf.selfip.com or on my LAN http://192.168.0.25

I had fedora 8 such as being able to see my www folder or the apache welcome page. And I know others could see it from the web. Thats why I know it has to be the server settings at least I think

Thanks for any help.

Matt
matt
Check within firefox to see if http://localhost brings up your website.
If not Apache isn't running and you may have to start the server.

If you don't have apache from the terminal.

# yum install httpd

To start apache

# chkconfig httpd on
# /etc/init.d/httpd start

As well you may want to verify port 80 is Open.

# netstat -tulpn | grep :80

BUT Most importantly make sure 80, 443 and any other imp ports like 22
if your using ssh over the net are properly forwarded through your router
to 192.168.0.25. Its under applications on the wrt router... But im not sure.
I modded mine with OpenWRT firmware so i could just use Iptables to do the work
but thats another story.

Hope i'm some help

Matt
mhauth
[root@localhost ~]# yum install httpd
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.3 kB 00:00
primary.sqlite.bz2 100% |=========================| 1.9 MB 00:02
Setting up Install Process
Parsing package install arguments
Package httpd - 2.2.6-1.fc7.i386 is already installed.
Nothing to do
[root@localhost ~]# chkconfig httpd on
[root@localhost ~]# /etc/init.d/httpd start
Starting httpd:
[root@localhost ~]# netstat -tulpn | grep :80
tcp 0 0 :::80 :::* LISTEN 3174/httpd
[root@localhost ~]#

Thanks for the suggestion.


I then went and made sure ports 22, 80 and 443 were forwarded. Still nothing... hmm...

could it be how I have my /etc/hosts file set up?

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
192.168.0.25 evolutionofgolf.selfip.com matts-server
::1 localhost6.localdomain6 localhost6

Thanks in advance!

Matt
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.