Help - Search - Members - Calendar
Full Version: installing a lan card
Linuxhelp > Support > Technical Support
alex905
i have just installed esx server from vmware which as far as i know is a moded version of redhat. i just brought that lan card and put it in. when intsalling the os it seemed to pick it up straight away. and it wanted to use the tulip driver and infact on the driver cd tuplip is given. so i thought it was all well uptill i tried logging in through the browser insterface. it came up with nothing. so i did ifconfig which only showed the lo device. i then did a lsmod tulpis ind it brought up this.

vmnixmod size 3
mousedev
hid
input
usb-uhci
usbcore


but no network drive.

im not very good with linuk so im not sure what the interface is called. i tried ifconfig eth0 up but i dont know how to check if its called eth0 or somehting else. their is no gui just a bash.

i then tried netconfig. it worked fine and i restarted the box. it still dident come up.


so i thought maybe the driver wasent installed after all so i went to the cd and got the file off it and when i typed in make i got


gcc -DMODULE -D__KERNEL__ -Wall -Wstrict-prototypes -06 -I/usr/src/linux/include -pipe -fno-strength-reduce -DMODVERSIONS -c -o pci-scan.o pci-scan.c
pci-scan.c: In function 'init_module':
pci-scan.c:558: wrning: implicit declaration of fundction 'apm_register_callback'
pci-scan.c: In function 'cleanup_module':
pci-scan.c:565: warning : implicit declaration of function 'apm_unregister_callback'
gcc -DMODULE -D__KERNEL__ -Wall -Wstrict-prototypes -06 -I/usr/src/linux/include -pipe -fno-strength-reduce -DMODVERSIONS -c -o tulip.o tulip.c
tulip.c: In function 'tulip_open':
tulip.c:1488: structure has no member named 'tbusy'
tulip.c:1489: structure has no member named 'start'
tulip.c: In function 'tulip_start_xmit':
tulip.c:2607: structure has no member named 'tbusy'
tulip.c:2640: structure has no member named 'tbusy'
tulip.c: In function 'tulip_interrupt':
tulip.c:2659: structure has no member named 'interrupt'
tulip.c:2663: structure has no member named 'interrupt'
tulip.c:2744: structure has no member named 'tbusy'
tulip.c:2748: structure has no member named 'tbusy'
tulip.c:2845: structure has no member named 'interrupt'
tulip.c: In function 'tulip_close':
tulip.c:2991: structure has no member named 'start'
tulip.c:2992: structure has no member named 'tbusy'
tulip.c: In function 'tulip_get-stats':
tulip.c:3031: structure has no member named 'start'
tulip.c: In function 'private_ioctl':
tulip.c:3117: "SIOCSPARAMS' undeclared (first use in this function)
tulip.c:3117: (Each undeclard identifier is reported only once
tulip.c:3117: for each function it appears in.)
tulip.c: In function 'set_rx_mode':
tulip.c:3303: structure has no member named 'tbusy'
make: *** [tulip.o] Error 1

after this i downloaded some stuff form the tulip site and when i try and install it with the make command i get

make: *** no rule to make target 'pci-scan.h', needed by 'pci-scan.o'.

i dont need that file so i thought if i used the command make tulip i would get something. i got this:

make: *** no rule to make target 'pci-scan.h', needed by 'tulip.o'.

the files are here
ftp://ftp.scyld.com/pub/network

i think these are the right files anyway.

so now im stuck. i have no idea on what to do next.


any help will be greatly apriciated.
alex905
i mnanaged to install the driver from that website. a small error on my part. but now i cant send data through it. i firstly restered my pc, then i did a ifconfig to see if it was their. then i types in netconfig and set it up using a static private ip. i then rested the netowrk in init.d, i couldent ping my router. somehgting i used to be ale to do on my last linux install. so i set the deive to be set by dhcp, i restarted it again but it still dident work. my router is showing the plug were that pc is pkuged in to be in use but no data trasfer. i tried a diffrent cabel and a diffrent port on my router but it dident work.

any idea what it could be. and please for the love of all thats holy dont say its the driver.
michaelk
After you configured the network for DHCP did the computer actually get a valid IP address from the router?

What is the output of the commands:

ifconfig eth0

mii-tool
alex905
no it dosent.

eth0 link encap:ethernet hwaddr 00:18:f8:0b:2f:52
inet addr:192.168.1.5 bcast:192.168.1.225 mask:255.255.255.0
up broadcast running multicast mtu:1500 metric:1
rx packets:0 errors:0 dropped:659 overruns:0 frame0
tx dito apart from droped which is 0
txqueuelen:100
interupt:3 base address:0x5c00

and


eth0: negotiated 100basetx-fd flow-control, link ok

i hope that helps
michaelk
At first glance it appears to be ok but you still can not ping your router? I assume your router's addresss is 192.168.1.1?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.