Help - Search - Members - Calendar
Full Version: FC6 emacs startup extremely slow
Linuxhelp > Support > Technical Support
wkhk
Hello,
after installing FC6 from scratch (standard installation, no upgrade) and installing emacs via "yum install emacs"
I noticed the emacs startup time is extremely long (~30s!!!). So it's completely unusable for me.
I found somewhere that putting

(modify-frame-parameters nil '((wait-for-wm . nil)))

in my .emacs file should fix such a problem, but it doesn't in my case. I used emacs on all previous FC versions
and never had any problems. It doesn't seem to be related to X, since "emacs -nw" is as slow. I tried Gnome, KDE, and command line. No change.

Any ideas? Do I need additional software?

Thanks,
wkhk
Hemant
That is wierd, Do you have swap enabled?

If no...please consider enabling swap.

Can I have a look at contents of your .emacs file?

Also, try emacs-snapshot package. It contains the latest builds.
wkhk
QUOTE (Hemant @ Dec 6 2006, 05:49 PM) *
That is wierd, Do you have swap enabled?

If no...please consider enabling swap.

Can I have a look at contents of your .emacs file?

Also, try emacs-snapshot package. It contains the latest builds.


Hi,
thanks for the response. I certainly could post the .emacs file, but the
problem is not related to that file, since the problem persists when I
remove my .emacs file completely.
Yes, swap is enabled and it's 2*RAM, i.e. 2 GB.
I noticed that the problem is related to networking. When I am connected
to a wireless network that has no WEP key enabled, it's fine. As soon
as I connect to a WEP key enabled network emacs (and emacs -nw) is
slow. I'm wondering whether it's related to the firewall or selinux????

Any hints, ideas are highly appreciated.

Thanks again,
w.
Hemant
turn off selinux, its hardly useful on notebooks.

since u are saying that problem is mostly when Wireless is enabled, I would assume other programs would also slow down.

anyway, consider posting message to the emacs mailing list,

http://lists.gnu.org/mailman/listinfo/help-gnu-emacs

but please try posting as much information as possible. Also, tell us about Emacs version you are using and what happens when you switch to Emacs snapshot.
wkhk
QUOTE (Hemant @ Dec 7 2006, 07:58 AM) *
turn off selinux, its hardly useful on notebooks.

since u are saying that problem is mostly when Wireless is enabled, I would assume other programs would also slow down.

anyway, consider posting message to the emacs mailing list,

http://lists.gnu.org/mailman/listinfo/help-gnu-emacs

but please try posting as much information as possible. Also, tell us about Emacs version you are using and what happens when you switch to Emacs snapshot.


Hi again,
ok, I turned off selinux. That did not solve the problem. I really believe it's the WEP key. I am not really
sure what to post. I used first emacs version that comes with FC6 (21-???). After contacting fedora-bugzilla
it was recommended to me to upgrade to emacs-22. So I have presently emacs-22.0.90-1.fc6 installed.
No change.

I run gnome and network-manager.

I'll contact the emacs mailing list.

Thanks.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.