Hello all,
I am running RHEL 4 with all updates on an x86 Dell Poweredge server.
Recenlty, i have been having some troubles with my openssl installation. I think the problem has to do with the fact that I have openssl-0.9.7a-43.14 installed with apache 2.2.3 and php 5.1.6.
this verison of openssl is old, but it's the most recent one offered by RedHat. So now, I want to upgrade my version of ssl but i'm not sure how because i don't have an rpm for it and i don't know how to build a package to replace an rpm.
when i try to run
rpm -e openssl-0.9.7a-43.14 openssl-devel-0.9.7a-43.14

CODE
error: Failed dependencies:
        openssl-devel is needed by (installed) curl-devel-7.12.1-8.rhel4.i386
        libcrypto.so.4 is needed by (installed) pine-4.63-1.1.el3.rf.i386
        libcrypto.so.4 is needed by (installed) cyrus-sasl-2.1.19-5.EL4.i386
        libcrypto.so.4 is needed by (installed) cyrus-sasl-md5-2.1.19-5.EL4.i386
        libcrypto.so.4 is needed by (installed) authd-1.4.3-2.i386
        libcrypto.so.4 is needed by (installed) lftp-3.0.6-3.i386
        libcrypto.so.4 is needed by (installed) pyOpenSSL-0.6-1.p23.i386
        libcrypto.so.4 is needed by (installed) stunnel-4.05-3.i386
        libcrypto.so.4 is needed by (installed) libwvstreams-3.75.0-2.i386
        libcrypto.so.4 is needed by (installed) elinks-0.9.2-3.2.i386
        libcrypto.so.4 is needed by (installed) fetchmail-6.2.5-6.el4.2.i386
        libcrypto.so.4 is needed by (installed) gnome-vfs2-2.8.2-8.2.i386
        libcrypto.so.4 is needed by (installed) hpoj-0.91-9.i386
        libcrypto.so.4 is needed by (installed) xchat-2.4.0-3.EL4.0.i386
        libcrypto.so.4 is needed by (installed) pwlib-1.6.5-11.i386
        libcrypto.so.4 is needed by (installed) openh323-1.13.4-7.i386
        libcrypto.so.4 is needed by (installed) libgnomecups-0.1.12-5.i386
        libcrypto.so.4 is needed by (installed) libgnomeprint22-2.8.0-3.i386
        libcrypto.so.4 is needed by (installed) desktop-printing-0.17-3.EL.1.i386
        libcrypto.so.4 is needed by (installed) perl-Crypt-SSLeay-0.51-5.i386
        libcrypto.so.4 is needed by (installed) cyrus-sasl-devel-2.1.19-5.EL4.i386
        libcrypto.so.4 is needed by (installed) nmap-3.70-1.i386
        libcrypto.so.4 is needed by (installed) curl-7.12.1-8.rhel4.i386
        libcrypto.so.4 is needed by (installed) lynx-2.8.5-18.2.i386
        libcrypto.so.4 is needed by (installed) wget-1.10.2-0.40E.i386
        libcrypto.so.4 is needed by (installed) Nessus-3.0.1-es4.i386
        libcrypto.so.4 is needed by (installed) NessusClient-1.0.0.RC4-es4.i386
        libcrypto.so.4 is needed by (installed) freeradius-1.0.1-3.RHEL4.3.i386
        libcrypto.so.4 is needed by (installed) ipsec-tools-0.3.3-6.rhel4.1.i386
        libcrypto.so.4 is needed by (installed) postgresql-libs-7.4.13-2.RHEL4.1.i386
        libcrypto.so.4 is needed by (installed) postgresql-7.4.13-2.RHEL4.1.i386
        libcrypto.so.4 is needed by (installed) postgresql-devel-7.4.13-2.RHEL4.1.i386
        libcrypto.so.4 is needed by (installed) spamassassin-3.0.6-1.el4.i386
        libcrypto.so.4 is needed by (installed) mutt-1.4.1-11.rhel4.i386
        libcrypto.so.4 is needed by (installed) net-snmp-libs-5.1.2-11.EL4.7.i386
        libcrypto.so.4 is needed by (installed) openldap-2.2.13-6.4E.i386
        libcrypto.so.4 is needed by (installed) cups-libs-1.1.22-0.rc1.9.11.i386
        libcrypto.so.4 is needed by (installed) samba-common-3.0.10-1.4E.9.i386
        libcrypto.so.4 is needed by (installed) net-snmp-5.1.2-11.EL4.7.i386
        libcrypto.so.4 is needed by (installed) bind-libs-9.2.4-16.EL4.i386
        libcrypto.so.4 is needed by (installed) ruby-libs-1.8.1-7.EL4.6.i386
        libcrypto.so.4 is needed by (installed) bind-utils-9.2.4-16.EL4.i386
        libcrypto.so.4 is needed by (installed) ntp-4.2.0.a.20040617-4.EL4.1.i386
        libcrypto.so.4 is needed by (installed) iiimf-server-12.1-13.EL.5.i386
        libcrypto.so.4 is needed by (installed) net-snmp-utils-5.1.2-11.EL4.7.i386
        libcrypto.so.4 is needed by (installed) openldap-clients-2.2.13-6.4E.i386
        libcrypto.so.4 is needed by (installed) samba-3.0.10-1.4E.9.i386
        libcrypto.so.4 is needed by (installed) bind-9.2.4-16.EL4.i386
        libcrypto.so.4 is needed by (installed) samba-swat-3.0.10-1.4E.9.i386
        libcrypto.so.4 is needed by (installed) cups-1.1.22-0.rc1.9.11.i386
        libcrypto.so.4 is needed by (installed) postfix-2.2.10-1.RHEL4.2.i386
        libcrypto.so.4 is needed by (installed) evolution-connector-2.0.2-10.rhel4.1.i386
        libcrypto.so.4 is needed by (installed) gftp-2.0.17-6.i386
        libcrypto.so.4 is needed by (installed) kdebase-3.3.1-5.13.i386
        libcrypto.so.4 is needed by (installed) wireshark-0.99.3-EL4.2.i386
        libcrypto.so.4 is needed by (installed) openssh-3.9p1-8.RHEL4.17.i386
        libcrypto.so.4 is needed by (installed) openssh-clients-3.9p1-8.RHEL4.17.i386
        libcrypto.so.4 is needed by (installed) openssh-server-3.9p1-8.RHEL4.17.i386
        libcrypto.so.4 is needed by (installed) python-2.3.4-14.3.i386
        libcrypto.so.4 is needed by (installed) kdelibs-3.3.1-6.RHEL4.i386
        libssl.so.4 is needed by (installed) pine-4.63-1.1.el3.rf.i386
        libssl.so.4 is needed by (installed) lftp-3.0.6-3.i386
        libssl.so.4 is needed by (installed) pyOpenSSL-0.6-1.p23.i386
        libssl.so.4 is needed by (installed) stunnel-4.05-3.i386
        libssl.so.4 is needed by (installed) libwvstreams-3.75.0-2.i386
        libssl.so.4 is needed by (installed) elinks-0.9.2-3.2.i386
        libssl.so.4 is needed by (installed) fetchmail-6.2.5-6.el4.2.i386
        libssl.so.4 is needed by (installed) gnome-vfs2-2.8.2-8.2.i386
        libssl.so.4 is needed by (installed) xchat-2.4.0-3.EL4.0.i386
        libssl.so.4 is needed by (installed) pwlib-1.6.5-11.i386
        libssl.so.4 is needed by (installed) openh323-1.13.4-7.i386
        libssl.so.4 is needed by (installed) libgnomecups-0.1.12-5.i386
        libssl.so.4 is needed by (installed) libgnomeprint22-2.8.0-3.i386
        libssl.so.4 is needed by (installed) desktop-printing-0.17-3.EL.1.i386
        libssl.so.4 is needed by (installed) perl-Crypt-SSLeay-0.51-5.i386
        libssl.so.4 is needed by (installed) cyrus-sasl-devel-2.1.19-5.EL4.i386
        libssl.so.4 is needed by (installed) nmap-3.70-1.i386
        libssl.so.4 is needed by (installed) curl-7.12.1-8.rhel4.i386
        libssl.so.4 is needed by (installed) lynx-2.8.5-18.2.i386
        libssl.so.4 is needed by (installed) wget-1.10.2-0.40E.i386
        libssl.so.4 is needed by (installed) Nessus-3.0.1-es4.i386
        libssl.so.4 is needed by (installed) NessusClient-1.0.0.RC4-es4.i386
        libssl.so.4 is needed by (installed) freeradius-1.0.1-3.RHEL4.3.i386
        libssl.so.4 is needed by (installed) ipsec-tools-0.3.3-6.rhel4.1.i386
        libssl.so.4 is needed by (installed) postgresql-libs-7.4.13-2.RHEL4.1.i386
        libssl.so.4 is needed by (installed) postgresql-7.4.13-2.RHEL4.1.i386
        libssl.so.4 is needed by (installed) postgresql-devel-7.4.13-2.RHEL4.1.i386
        libssl.so.4 is needed by (installed) spamassassin-3.0.6-1.el4.i386
        libssl.so.4 is needed by (installed) mutt-1.4.1-11.rhel4.i386
        libssl.so.4 is needed by (installed) openldap-2.2.13-6.4E.i386
        libssl.so.4 is needed by (installed) cups-libs-1.1.22-0.rc1.9.11.i386
        libssl.so.4 is needed by (installed) samba-common-3.0.10-1.4E.9.i386
        libssl.so.4 is needed by (installed) ruby-libs-1.8.1-7.EL4.6.i386
        libssl.so.4 is needed by (installed) iiimf-libs-12.1-13.EL.5.i386
        libssl.so.4 is needed by (installed) iiimf-server-12.1-13.EL.5.i386
        libssl.so.4 is needed by (installed) openldap-clients-2.2.13-6.4E.i386
        libssl.so.4 is needed by (installed) samba-3.0.10-1.4E.9.i386
        libssl.so.4 is needed by (installed) samba-swat-3.0.10-1.4E.9.i386
        libssl.so.4 is needed by (installed) cups-1.1.22-0.rc1.9.11.i386
        libssl.so.4 is needed by (installed) postfix-2.2.10-1.RHEL4.2.i386
        libssl.so.4 is needed by (installed) evolution-connector-2.0.2-10.rhel4.1.i386
        libssl.so.4 is needed by (installed) gftp-2.0.17-6.i386
        libssl.so.4 is needed by (installed) kdebase-3.3.1-5.13.i386
        libssl.so.4 is needed by (installed) python-2.3.4-14.3.i386
        libssl.so.4 is needed by (installed) kdelibs-3.3.1-6.RHEL4.i386
        openssl is needed by (installed) libpcap-0.8.3-10.RHEL4.i386
        openssl is needed by (installed) perl-Crypt-SSLeay-0.51-5.i386
        openssl is needed by (installed) curl-7.12.1-8.rhel4.i386
        openssl is needed by (installed) Nessus-3.0.1-es4.i386
        openssl is needed by (installed) NessusClient-1.0.0.RC4-es4.i386
        openssl is needed by (installed) postfix-2.2.10-1.RHEL4.2.i386
        openssl >= 0.9.6b is needed by (installed) srvadmin-old-5.1.0-354.i386
        openssl = 0.9.7a is needed by (installed) kdelibs-3.3.1-6.RHEL4.i386


also (this might help)
CODE
[drag0ner@www ~]$ which openssl
/usr/local/bin/openssl


if anyone could help me out that would be greatly appreciated. basically, i just want to get rid of my rpm installation of openssl and build my own without breaking these dependencies.

Thanks in advance