Help - Search - Members - Calendar
Full Version: HELP ASAP need to static link net-tools-1.60
Linuxhelp > Support > Technical Support
adagre
HI all I am a Computer Security student and my current lab entails me to compile certain binaries as statically linked for purposes of a forensic examination toolkit.

So my problem is I can't for the life of me get net-tools-1.60 to statically link when I run make CC="gcc -static"

I run the file command against arp in /sbin and it still says dynamically linked

I also get an error at the end of the make command output:

inet_sr.c: In function ‘INET_setroute’:
inet_sr.c:108: error: label at end of compound statement
inet_sr.c:200: error: ‘HZ’ undeclared (first use in this function)
inet_sr.c:200: error: (Each undeclared identifier is reported only once
inet_sr.c:200: error: for each function it appears in.)
make[1]: *** [inet_sr.o] Error 1
make[1]: Leaving directory `/tmp/net-tools-1.60/lib'
make: *** [subdirs] Error 2

Does this have anything to do with it??

What should I do I am running out of time to get this thing done

I am running openSuse 10.2 alpha 4

Thanks in advance
adagre
Having similar problem with Recode... I think the porblem with recode is the usage of systax to set the libraries to compile statically?

I have tried LDFLAGS="-static"
export LDFLAGS

tried ./configure --enable-static-link

tried CFLAGS=-static
export CFLAGS

It compiles with no errors but when I go to /recode-3.6/src and run file against the executable recode, it comes back as dynamically linked eveytime, I find I am having alot of sucess with LDFLAGS on other source packages.
Any help out there?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.