Help - Search - Members - Calendar
Full Version: Adsl Modem Problems
Linuxhelp > Support > Technical Support
bigbaz
I have installed Redhat 8 but am unable to get my Modem an Alcatel Speedtouch 330 up and running.

I was directed to a how to page at www.xs4all.nl/~pschram/english.html

It tells me to download a microde, drivers and configuration files. These I have downloaded to a floppy disc while running Windows XP

Should I open these files when downloaded to the floppy or leave them compressed.

When I work in Linux I am told to first unpack the microde with :

cd /tmp/tar -zxvf speedmgmt.tar.gz

Am I wrong in assuming that this command assumes the microde has already been downloaded to Linux?

How can I get it from the floppy to the correct place, nothing I do seems to work.

Help please and please remember that I am a complete novice as far as Linux goes.. sad.gif


Best Wishes Barry
frodo44
I'm not quite sure what you're asking here, but I guess I'll go ahead and assume. What I got was that you were concerned that the file might not decompress correctly if you had downloaded it from windows. If you have the files available from Linux, it shouldn't matter if you've downloaded from Windows or Linux. Other than that, I don't know what to tell you. By the way, when you run the tar decompression program, you can just do something like this

Oh, wait a minute. I just came upon something. By the command line you gave, were you trying to navigate into the tar archive? If so, you might want to decompress it first, then navigate into it. You would do that like this:

tar -xvzf speedmgmt.tar.gz
//which should give you a file called speedmgmt
cd speedmgmt

you then should be in the same place, only you not limited by the fact that you are navigating a compressed file. Hope this helps. I've seen a lot of horror stories by people with DSL modems not working under Linux.

Eric
frodo44
Ok,

I just went and read the article you cited. If you were getting a problem with linux not finding the file, it's probably because it wasn't in the /tmp directory like the article was using. I'm not sure what directory you put the file on, or if you ever got it off of the floppy. I guess I can give you a little help with what to do if it still is on the floppy.

First you want to mount the floppy:

mount /dev/fd0 /mnt/floppy
cd /mnt/floppy
cp speedmgmt.tar.gz ~/speedmgmt.tar.gz
cd ~
tar xvzf speedmgmt.tar.gz
cd speedmgmt
cp mgmt.o /usr/local/lib/mgmt.o

I'm not sure where you go from there, but that't what you would do to get the file where the article said. By the way, '~' is a shortcut to your user directory. If you're working as root it's going to be /root, but if you're a regular user it's going to be /home/*username*. Don't worry about that though, the ~ will work fine for the commands.

Hope that helped a little more.

Eric
bigbaz
Thanks for the help Eric, you were right in the fact that I couldnt get it off the floppy disc.

Following what you gave me I find that the last command I need is

tar xvzf speedmgmt.tar.gz

then i have to input

cp mgmt/mgmt.o /usr/local/lib/

That appear to be the microcode in and working. biggrin.gif

Next problem and this shows just how green I am ph34r.gif

How then do I unpack the driver, the instructions say

cd /tmp/

My system says no so I tried remounting the floppy and Im told its mounted

I have tried following your earlier instructions and altering them but I cannot get it right

Help Regards Barry
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.