Help - Search - Members - Calendar
Full Version: Partitions won't mount!
Linuxhelp > Support > Technical Support
Lisally14
Linux won't mount my /home and windows partitions; I get an error saying access is denied.

The home partition is formatted as ext 3, the winows partition as vfat32.


I'm running Fedora Core 5 with KDE.


Any suggestions?
michaelk
/home if it is configured as a seperate partition should automatically mount at bootup. Please post your /etc/fstab file. To see what filesystems are already mounted use the mount command without options.

To mount your windows FAT32 partition
1. Create a directory to use as a mount point.i.e mkdir /media/windows_drive
2. Add an entry to the /etc/fstab file. i.e
/dev/hda1 /media/windows_drive vfat umask=000 0 0

You must be root to edit the /etc/fstab file. Change /dev/hda1 to match the partition of your windows drive.
Lisally14
QUOTE (michaelk @ Aug 19 2006, 10:38 PM) *
/home if it is configured as a seperate partition should automatically mount at bootup. Please post your /etc/fstab file. To see what filesystems are already mounted use the mount command without options.

To mount your windows FAT32 partition
1. Create a directory to use as a mount point.i.e mkdir /media/windows_drive
2. Add an entry to the /etc/fstab file. i.e
/dev/hda1 /media/windows_drive vfat umask=000 0 0

You must be root to edit the /etc/fstab file. Change /dev/hda1 to match the partition of your windows drive.


Thanks for the reply.

editing the fstab file doesn't work, even as root.


I can mount my windows drive manually using terminal commands, but I must remount it each tiime I log in. Is there a way to mount automatically without the terminal commands?

the system:/media directory lists the partition as present, but won't mount. Using the terminal command is the only i can get it to mount!
michaelk
You need to add an entry in the fstab file as previously posted to automatically mount the filesystem at bootup.

What are you using to edit the fstab file?
Lisally14
I'm using Kwrite-that's what it opens with, so it's probably the wrong program tongue.gif

What do you suggest using to edit it?
michaelk
If your root then it should work. I use the console for most configuration changes and use the vi editor.
Lisally14
Got it to work! biggrin.gif

Thanks so much for all your help!!!!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.