Help - Search - Members - Calendar
Full Version: How do I discover what's blocking my audio?
Linuxhelp > Support > Technical Support
Ben Pont
I seemed to have lost audio for some inexplicable reason. I wasn't doing anything out of the ordinary and the only active processes to speak of are two torrents I'm downloading with bittornado. I'd rather not close them at the moment since I'm getting good bandwidth.

Any troubleshooting suggestions?
Jim
Logs logs logs logs logs.

If you haven't already, check your logs. Check these first (depending on your OS you will have one or the other)

/var/logs/messages
/var/log/system

do an ls on /var/logs see if there is anything else interesting, like maybe audio, but probably not. Always start with logs.
Ben Pont
QUOTE (Jim @ Aug 14 2006, 11:46 PM) *
Logs logs logs logs logs.

If you haven't already, check your logs. Check these first (depending on your OS you will have one or the other)

/var/logs/messages
/var/log/system

do an ls on /var/logs see if there is anything else interesting, like maybe audio, but probably not. Always start with logs.



Thanks for the quick response. I use Gentoo, which has ten billion different logs! In spite of that: /var/logs/messages and /var/log/system are non-existent. I'm checking on the Gentoo forum as well...no responses yet...

Here is the output when I tried to play an audio file using madplay in a terminal:
QUOTE
MPEG Audio Decoder 0.15.2 (beta) - Copyright 2000-2004 Robert Leslie et al.
ALSA lib pcm_dmix.c:862:(snd_pcm_dmix_open) unable to open slave
audio: esd_open_sound() failed

Jim
Sorry, gentoo uses /var/log/syslog I forgot to list that one.

Gut instinct is that your alsa module isn't loaded

Run lsmod and make sure that the alsa module is loaded

Otherwise, run modprob -l to get a list of available modules, and then load the alsa module with modprobe whateverAslaIsCalled (note you wont need the full path like it displays, just the last part.

But start with syslog again and see what it tells you.
DS2K3
If you're using metalog on Gentoo (like me), then it might be in /var/log/everything/current

D
Ben Pont
QUOTE (Jim @ Aug 15 2006, 10:47 AM) *
Sorry, gentoo uses /var/log/syslog I forgot to list that one.

Gut instinct is that your alsa module isn't loaded

Run lsmod and make sure that the alsa module is loaded

Otherwise, run modprob -l to get a list of available modules, and then load the alsa module with modprobe whateverAslaIsCalled (note you wont need the full path like it displays, just the last part.

But start with syslog again and see what it tells you.


Actually, it was my bittorrent client (bittornado) that was somehow locking my audio device, so that no other app could access it! I don't even know why it would do this as it has no sound events so far as I can tell and there are no sound options in the preferences menu! How can I prevent this or any other app from locking down my sound device. It's nice to download a torrent in the background and still be able to have sound on my computer!!
Jim
Humm.... thats a good question.

One of the things that linux has issues with is sharing the audio between two programs.

[Linux explinations skip if you could care less]

In linux, pretty much everything is represented by a file. Like your hard drive, its a file, say /dev/hda, and the partition might be /dev/hda1 by writting to, and reading from that file in a very special way you can write and read from the disk. So your sound car is /dev/sound (usually, not always). So again, if you read and write from that in a very special way, you can play (or record) sound. In order to have two things writting at the same time, you would have to have some way of blending the audio first, then writting to /dev/sound

[end]

To answer you question I am not sure there is any "simple" way to keep bit torrnado from locking up your sound. I would look through your settings and preferences for BT and make sure that there isn't anything you can disable (anything related to sound would be a good start). It might be that its grabbing the sound card to notify you when a file is finished and not releasing it correctly.

Ya so, I have no golden fix for you on this one.

Wait, though, is bittornado a command line program or a gui? If its a command line program, you could run it from one of the other terminals and it probably wouldn't grab sound. Just a thought, I assume bittornado is a gui though, so that doesn't help you.
DS2K3
Try starting your music player or whatever before you start BitTornado. Of, if poss, sere if you can instruct BitTornado to use an alternative sound system like Arts. If arts is running and you instruct all your programs to use it (KDE programs should use it by defauly anyway)then it usually does a pretty good job of mixing the various sounds for you.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.