Help - Search - Members - Calendar
Full Version: can't boot need help with rhel4
Linuxhelp > Support > Technical Support
POTHI
Urgent help needed!!!!!!!!!

when I boot my computer OS/2 with windows xp and RHEL4

I get Checking root file system
fsck.ext2: Is a directory while trying to open/ [FAILED]

***An error occured during the file system check
***Droping you to shell, the system ill reboot
***when ou leve the shell.
***warning -- SELinux is active
***Disabling security enforcement for system recovery.
***Run 'setenforce 1' to reenable

Give root Password for maintenance
(or type Control-D to Continue):

1) if I press Control-D the computer rebootss and same error message again

2) if I give the root passord, it goes to shell
(Repair file system)1#

I am new to linux, so detailed help would be really appreciated. Thankx in advance. looking to hear as soon as possible.
dishawjp
Probably the easiest way would be to allow the computer to boot to a root shell. Then type the following command:

touch /forcefsck

and then type:

shutdown -r now

The computer will then reboot and run a complete fsck. In most cases you will not be prompted for any input, just let it run. After that completes, you may want to run an autocheck of your SELinux contexts. To do that, in a root shell, type the following:

touch /.autorelabel

and let it do it's thing. This can take a LONG time to run depending on the number of files and drives and processor speed and all. You may want to have a cold six pack (or two) handy when you run these.

HTH,

Jim
POTHI
Hi Jim,

thankx for your reply.

First I did not know how to go into root shell. But here is hat I did and what I got.

I booted the computer into RHEL and it gave the usual error message

Give root Password for maintenance
(or type Control-D to Continue):

I typed the root password and It ent to the promt like this

(Repair file system)1#

then I typed touch /forcefsck

I got the message

touch: cannot touch '/forcefsck' : Red-Only file system

then I tried

mount -o remount,r /
touch /forcefsck (If did nothing)
then I typed shutdown -r now

it rebooted and I got the same message that I ussed to get


Give root Password for maintenance
(or type Control-D to Continue):
DS2K3
Give your too password, and then run fsck /dev/hda1 - A lot of errors you can just accept what it reccoemnds - obv if you start getting loads of messages then something might have gone badly wrong - in which case let us know what it says and we might be able to offer a solution to the specific disk problem.

D
POTHI
hi,

this took so long and was not able to fix the problem. so i backed the importnt data using usb and I formaatted.

thankx for our help and I reall appreciate it.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.