Help - Search - Members - Calendar
Full Version: Home network
Linuxhelp > Support > Technical Support
krneki
Hello!
I have two computers at home. First works as a router and server (OS is Fedora Core 3 without graphics) and the second one is main computer (OS is Windows XP SP2) so connection looks like this: modem -> linux -> windows. Internet and home network were working fine for three months until yesterday when suddenly modem died and also my home network (I wasn't at home). I changed modem with new one and internet is working fine now on Fedora 3 but I can't figure out what is wrong with home network because internet on WinXP is simply not working. However, I can still ping from WinXP to Linux and from Linux to WinXP. I can also connect with putty to Linux router but internet on WinXP box is still not working (there are 0 received packages).
I don't have Samba on linux, I only configured network by one tutorial (which I can't find anymore).
Do you have any ideas what should I do now? I didn't change any network settings last month.

Thank you very much,
regards krneki
michaelk
Make sure that ipfoward is still set i.e. echo "1" > /proc/sys/net/ipv4/ip_forward and your firewall has not changed.

Is the windows PC configured for DHCP or a static IP address? If using a static IP address make sure the nameservers have not changed.

From the windows PC try pinging google's IP address:
ping 64.233.187.99

If that works but pinging google.com does not then it is a DNS issue.
krneki
I aplied echo "1" > /proc/sys/net/ipv4/ip_forward but it was already set to 1 in that file. Where can I look and how can I know if firewall settings had changed?
Windows PC is configured to static IP address: IP - 192.168.0.2 ; Subnet mask: 255.255.255.0 ; Default gateway: 192.168.0.1 ; Dns servers are from my ISP (they are same as on Linux PC).
I also tried to ping google's IP and I received message: network is not reachable.

Any new ideas?
michaelk
Post the output of iptables -L
krneki
There was a mess in eth0 with IP's. IP for internet was 192.168.0.2 but it was still working properly. However I changed that IP to my static IP and I can ping from Windows PC to Linux PC again (internet is still not working).

What do you mean by that "if I can ping the modem"? I can't ping it neither on Linux PC (ping 192.168.1.2).

I only have that in hosts file: 127.0.0.1 localhost

There were only 2 syntaxes in tutorial which I used for my network. Very simply, if I'm not wrong they started with ifconfig so I really don't know if there was used DHCP. Do you know how can I look for DHCP status and change it?

If I type "hostname" in console, I get: localhost.localdomain

I tried both: pinging domain and IP and none works. Anyway, here are some informations:

route -e:
[quote]Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
BSN-access.dsl. * 255.255.255.255 UH 0 0 0 ppp0
192.168.0.0 * 255.255.255.0 U 0 0 0 eth1
193.77.90.0 * 255.255.255.0 U 0 0 0 eth0
default BSN-access.dsl. 0.0.0.0 UG 0 0 0 ppp0[/quote]


ifconfig (linux):
[quote]eth0 Link encap:Ethernet HWaddr 00:C0:DF:E8:13:55
inet addr:193.77.90.205 Bcast:193.77.90.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:dfff:fee8:1355/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6000 errors:0 dropped:0 overruns:0 frame:0
TX packets:6662 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:740924 (723.5 KiB) TX bytes:867567 (847.2 KiB)
Interrupt:9 Base address:0xdd80

eth1 Link encap:Ethernet HWaddr 00:C0:DF:03:18:3E
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:dfff:fe03:183e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2000 errors:0 dropped:0 overruns:0 frame:0
TX packets:98 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:162084 (158.2 KiB) TX bytes:10333 (10.0 KiB)
Interrupt:10 Base address:0xda00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:18 errors:0 dropped:0 overruns:0 frame:0
TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1629 (1.5 KiB) TX bytes:1629 (1.5 KiB)

ppp0 Link encap:Point-to-Point Protocol
inet addr:193.77.90.205 P-t-P:213.250.19.90 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:4391 errors:0 dropped:0 overruns:0 frame:0
TX packets:5382 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:458859 (448.1 KiB) TX bytes:590301 (576.4 KiB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 cool.gif TX bytes:0 (0.0 cool.gif[/quote]


ipconfig (windows):
[quote]Windows IP Configuration

Host Name . . . . . . . . . . . . : domen
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : Yes
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethernet NIC
Physical Address. . . . . . . . . : 00-04-61-4A-23-B6
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.0.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 193.189.160.11
193.189.160.12[/quote]

iptables -L (linux):
[quote]Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
[/quote]
michaelk
Try adding the following rules:

iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
iptables -A FORWARD -i eth1 -j ACCEPT
krneki
Thank you very much, it's working! (at least for now) cool.gif
michaelk
Depending on what services are running on the linux PC you could be vunerable without some min firewall settings.

Lots of info can be found by googling.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.