Help - Search - Members - Calendar
Full Version: Configuring Sound Support In Mandrake 9.1
Linuxhelp > Support > Technical Support
edski
I was running Mandrake 9.0 and recently upgraded to 9.1 on my laptop but haven't managed to get sound working on either yet.
Running sndconfig, my sound card (NeoMagic) is automatically detected but then I am given the error:
sox: Can't open output file '/dev/dsp' no such device
when it tries to play a test sound.

Looking at the sound HOWTO, as far as I can work out I need to run 'make xconfig' and change sound support in the kernel but on typing that command I get:
make: *** No rule to make target 'xconfig'. Stop.

Is there:
a) A way to get xconfig to work? or
cool.gif A way to configure my soundcard without having to mess around with the kernel?

NB. I *have*:
-Tried chmod 666 /dev/dsp
-Installed the kernel-source rpm

Many thanks,

Edsk*
jetblackz
I had the opposite experience with 9.1 which, to date, is the only distro that detected my onboard sound automatically and properly.

Try chmod 777.

What does it show?

ls -la /dev/dsp
edski
Thanks for your reply.
ls -la /dev/dsp gave:
crw------- 1 edski audio 14, 3 Jan 27 22:59 /dev/dsp
And, after chmod 777 /dev/dsp i get:
crwxrwxrwx 1 edski audio 14, 3 Jan 27 22:59 /dev/dsp


However, running sndconfig still throws up the same error about /dev/dsp no such device... sad.gif
Any ideas?

Edsk*
jetblackz
On my Slack, it's a link

lrwxrwxrwx 1 root root 9 Mar 30 17:13 /dev/dsp -> /dev/dsp0

rm /dev/dsp
ln -s /dev/dsp0 /dev/dsp

If it doesn't work,

rm /dev/dsp
mknod /dev/dsp c 2 0

A reinstall would be the easiest.
Corey
As well, re-run "lsmod" as root to make sure that your sound modules are indeed being inserted into the kernel.
edski
Ok...

I tried both the methods suggested.

#rm /dev/dsp
#ln -s /dev/dsp1 /dev/dsp

and

#rm /dev/dsp
#mknod /dev/dsp c 2 0

In both cases, when running sndconfig I now get an error:

sox: Unable to reset OSS driver. Possibly accessing an invalid file/device.

Also, I ran lsmod. It gives me:

Module Size Used by Not tainted
lp 8128 0
parport_pc 25128 1
parport 34208 1 [lp parport_pc]
nm256_audio 70588 0 (unused)
sound 70676 0 [nm256_audio]
soundcore 6308 0 [sound]
...

nm256_audio (unused) looks like it might be a problem.
Apologies for not knowing much about the situation. If anyone can point me to a good guide on the internet so I can educate myself on the subject rather than following instructions blindly then I'll not have to bother you much more!

Cheers,
Edsk*
jetblackz
Search at www.google.com's newsgroups.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.