Help - Search - Members - Calendar
Full Version: Intel SR1425 server - getting SATA RAID working
Linuxhelp > Support > Hardware Support
brock
Hi,

I'm trying to setup an Intel SR1425 server (SE7221BK1E) which has an onboard SATA RAID controller, which, as far as I can make out, is really a software controller using Intel ICH6R based controller.

First I used SUSE9.0 server and it failed to recognize any disk controllers at all, so next I try SUSE10 for desktops and it recognise the controller but failes to enable any RAID. I look on the Intel site (http://downloadfinder.intel.com/scripts-df-external/Detail_Desc.aspx?agr=N&Inst=Yes&ProductID=1857&DwnldID=9851&strOSs=98&OSFullName=SUSE*%20Linux*%209.x&lang=eng) and download the drivers for the RAID controller, but when I follow the intructions it fails to load the driver file, the file is an .img file. I guess I'm doing something wrong but what? The version of SLES which Intel refer is slightly different, they refer to booting using SLES9.0 sp2, I just have SLES9.0, not sp2 - would this make a difference?

I'm also curious as how the RAID controller supports a hotspare, I have configured it as RAID1 + hotspare in the RAID BIOS but I have not seen this before on a software only RAID, I believe this Intel server chassis might a bot fo a hybrid, some where in the middle of software and hardware.

So, I can install the drivers for this controller? Assume a clean install from scratch, RAID1 with hotspare.

I'm a bit of a newbie with Linux and hardware.
brock
Well, I have now installled SUSE10.1 64bit and all seems OK - I yanked out one of the SATA drives and rebooted and the RAID card starting rebuilding. I had previously read (by doing a Google) that the Intel ICH6 chipset was a software RAID solution, software in the sense of similar lowcost onboard RAID, SilconImage, Promise and the such, this appears not to be the case.
brock
I was wrong it still doesn't work and Intel have advised that they have an issue with this now. sad.gif
This is using the onboard controller RAID1 + hotspare, SUSE is seeing at 3 separate drives, not 1 logical drive.

Anys, as a work around, I've installed an Intel SRCS16 RAID card, I'm installing SLES9 64bit. Boot from first CD and do all the usual, SLES recognises the RAID1 as 1 logical drive, great. It goes through installing all the packaages etc, and then reboots when it has finished, and then I get the following error message (very similar anyway)

VFS: Cannot open root device "<NULL>" or unknown-block(8,3)
Please append a correct "root=" boot option
Kernelpanic - not syncing: VFS: Unable to mount root fs on unknown-block(8,3)


So I guess I have to load the Intel drivers, (another server with a much older ICP Vortex RAID doesn't seem to have the problem at all - RAID1 recognised, boots no problems), so I boot using the CD, I've tried linux dd as a boot option and F6 update drivers but no good, I can use rawrite or dd to extract the driver image to a floppy but this server has no floppy drive - so how do I get the drivers loaded? I need a rawrite or dd to a CD ideally, how can I do this?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.