Help - Search - Members - Calendar
Full Version: getting FC5 to do NOTHING when I insert a CD
Linuxhelp > Support > Technical Support
holy Teach
Okay, I'm a longtime Linux user. This didn't used to be a problem, but as distros have gotten more user friendly they now do automatic things that I don't want them to. Usually I can figure out how to get back to the old behavior, but this is one that has me stymied.

I'm running Fedora Core 5 and use KDE. I have a SCSI controller and a SCSI CD-ROM drive, which lives at /dev/scd0.

In years past (with previous distros), when I put a CD into the drive, it would do nothing. It wouldn't scan the disk, wouldn't mount it, NOTHING. This is what I want, because 99.9% of the time I insert a CD-ROM it's so I can use command-line cdparanoia to rip the audio tracks off of it.

Under FC5's version of KDE (3.5.2-0.2.fc5, if you care), when I insert a CD, it spins up and makes a lot of noise, but does *not* mount the drive, though an icon appears on the desktop that will allow me to do so.

However, when I try to use cdparanoia, I get the following error message:

QUOTE
Error trying to open /dev/scd0 exclusively (Device or resource busy).


After much trial and error, I was able to determine that if I type

QUOTE
killall kio_audiocd


...and then wait two or three seconds, then cdparanoia has no problems and I can rip normally.

My question is:

1) What is the right way to fix this? I'm worried that killing kio_audiocd isn't the best thing to do.
2) How do I get this change to stick. I want to be able to insert CDs and have KDE leave them the heck alone . I can manually mount a drive if I want it mounted.
3) If possible, I'd still like KDE to automount flash drives and other removable media.

It seems like this ought to be easy, but I've searched in the control center, process list and man pages and haven't been able to quite figure out the culprit.

Thanks in advance.
Robert83
Hello,

try looking in the following files for the solution

/etc/sysconfig/autofs

/etc/auto.master
/etc/auto.misc

the package that does the automount is
rpm -q autofs

rpm -ql autofs , to list all installed files, so that you can find any config file, and all the documents it has.


Hope this helps move in to the right direction, and solve your issue.

Sincerely
Robert B
holy Teach
QUOTE (Robert83 @ Jun 1 2006, 08:43 AM) *
the package that does the automount is
rpm -q autofs


I tried your suggestion, but it didn't change anything. Even when I turn off the autofs service, I still experience the EXACT same behavior.

I did:

CODE
# service autofs stop


...then checked the process list to make sure. I then inserted an audio CD, and *something* still touches the drive, launching a couple kio_audio processes. And, as before, I can't get cdparanoia to be able to read from the drive until I 'killall kio_audio'.

Just to make sure, I also commented out the 'cd' line in /etc/auto.misc. Still no difference. I'm going to say that autofs is NOT responsible for launching 'kio_audio'. Any idea how I can find out what is?
dishawjp
I don't have a full answer to your question, but may be able to point you in a direction to look. FC5 is using "gnome-mount" for all this stuff and it's driving me nuts. There are no man pages for gnome-mount, though you can google it for some info. The former "mount" and "umount" commands are deprecated and barely usable for removable media like floppies, optical drives and even usb flashdrives.

HTH,

Jim
holy Teach
I take back my last post. After having commented out the 'cd' line in /etc/auto.misc, kio_audiocd no longer runs when I insert a disc.

I did before, but now that I've rebooted (and a few days later) it just works.

So I can't be certain if that's the difference, or if it's something else I did in the meantime, but my problem is now solved. Thanks for your help!
DS2K3
Glad it's sorted

* Closing *

D
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.