Help - Search - Members - Calendar
Full Version: sasl2
Linuxhelp > Support > Technical Support
mmoor
smptd.conf

pwcheck_method: auxprop
auxprop_plugin: sql
sql_engine: mysql
sql_hostname: 127.0.0.1
sql_user: mail
sql_password: bn1234
sql_database: mail
sql_select: select passwort from maila where email='%u@%r'

saslpasswd2 -c -u joetest.com joe
1234
1234

then netscape smile.gif compose outgoing server (tls)
mailserver: mail.joetest.com
user: joe@joetest.com
pass: 1234

<send>
password box comes up asking for the (password for joe@joetest.com on joetest.com)

mailog: sasl auth fail

I got this runing befor i made the reinstall, but holy thingy i can't remeber what the hell i did.
Termina
Are you aware that you have typos? Is that a direct copy/paste?

QUOTE
select passwort

QUOTE
from maila
mmoor
nope not typos smile.gif

table name is maila

password colum is passwort
Termina
I see. o_O

Clear
/var/log/mail.log
/var/log/mail.info
(these might be slightly diffrent depending on your distro)

Then restart your daemons (courier if you use it, postfix, etc.)

Please upload those files, and post links. smile.gif (there shouldn't be any sensitive info in those)
mmoor
dont have a mail.info only a maillog

nothing very silly in there.

May 26 09:02:18 uranus postfix/smtpd[7071]: warning: SASL authentication failure: Password verification failed
May 26 09:02:18 uranus postfix/smtpd[7071]: warning: 194-158-249-204.static.adslpremium.ch[194.158.249.204]: SASL PLAIN authentication failed
May 26 09:02:20 uranus postfix/smtpd[7071]: warning: 194-158-249-204.static.adslpremium.ch[194.158.249.204]: SASL LOGIN authentication failed
May 26 09:02:22 uranus postfix/smtpd[7071]: lost connection after AUTH from 194-158-249-204.static.adslpremium.ch[194.158.249.204]
May 26 09:02:22 uranus postfix/smtpd[7071]: disconnect from 194-158-249-204.static.adslpremium.ch[194.158.249.204]
mmoor
okay for some silly reasons sending mail works now, but don't ask me what i did unsure.gif

but now i have another thing..
Upon sending on mail.. in mailog
(mailbox /var/spool/virtual//joetest.com/joe)
^^
for some silly reason there is a (/) tomuch.

main.cf
virtual_mailbox_base = /var/spool/virtual

in mysql -> pbox
/joetest.com/joe

so in my opeion this should end up with /var/spool/virtual/joetest.com/joe
Dont have a clue where that silly postfix get that other (/) from sad.gif
mmoor
peww.. fixed that too, but havent a clue how
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.