Help - Search - Members - Calendar
Full Version: Full NTFS Support
Linuxhelp > Support > Technical Support
fullur
How do I get full NTFS support under Fedora Core 5? I have read only access, but I can't write to it. Also I couldn't figure out how to automount the NTFS volume when I start linux. I tried some directions I found but ended up with a bunch of stuff failing that had been working prior to that. It all came back when I removed the changes I had made though.

Fedora Core 5
Kernel Version 2.6
Using Gnome
Termina
You can enabled full NTFS write support using captive.

http://www.jankratochvil.net/project/captive/

After you have that working, in /etc/fstab

QUOTE
/dev/hdb1      /media/hdb1    captive-ntfs    users,umask=000,rw      0      2
fullur
no joy. I installed the rpm and changed /etc/fstab. My ntfs partition is /hda1. I assume I would need to change the entry you posted for me to reflect that. I tried it both ways. I saw something while Fedora was booting about captive-ntfs having an error but I don't know how to get that output to look at it more closely.
Termina
You don't have to restart.

Try 'mount /mnt/windows', or whatever you specified in /etc/fstab
fullur
Okay, found the problem. When captive tries to start, the system says something about not being able to find /var/lib/captive/ntoskrnl.exe. I checked and that file does not exist.
Robert83
Hi,

you need to get that file from a Windows Computer, Windows XP Probably

see

c:/windows/system32/ntoskrnl.exe

Sincerely
Robert B
fullur
I actually did that. I have a windows xp home sp2 install on the same hard drive (winxp=hda1, fc5=hda2) which I copied ntoskrnl.exe from to that directory. I then tried starting the captive service. It tried for about 10 minutes before I gave up. I then rebooted the computer and watched the output while it was booting fedora. I got some weird long error that was too long for me to read before it dissappeared. Something about the file not being tested or something. I then messed with some of my settings and now Yum isn't working. I think I am going to re-install fedora if I can't get Yum back after work tonight.
fullur
Okay, I ended up ditching that config since it was on my main pc and it was getting old switching between linux and windows. I now have linux on my older computer which for the time being has Win2000 on the other partition. I copied the ntoskrnl.exe and ntfs.sys files that captive said it needed and tried to mount the captive drive. It gave me an error,
"Attempted to load UNTESTED and possibly INCOMPATIBLE module: /var/lib/captive/ntfs.sys
You should get more recent identifications database: /etc/w32-mod-id.captivemodid.xml
Otherwise you may also force the loading by the option: --load-untested
aborting..."

I tried loading it up with the --load-untested option, but all I got was an 0 byte file where the ntfs partition should have been mounted. I really have no idea where to go from here... ideas?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.