Help - Search - Members - Calendar
Full Version: Detecting new hardware
Linuxhelp > Support > Hardware Support
I'm very new to Linux. I have the Fedora Core Publisher's Edition. When I plug in my usb thumb drive, I can't seem to find it on the system. I have tried a few different commands and it doesn't seem to detect it.

I also have a laptop and have instructions for installing drivers for a PCMCIA card and I'm having problems with that. The directions say to download the file to the /usr/src location. I either drag it over to the folder or extract to and get an error saying I don't have permissions. I am the only one using the computer and under the properties it says I have write, read and execute rights.

It sounds like a simple problem, but I can't figure it out, can anyone help me out???

Also remember I'm very new to Linux and don't understand too much.

The commands mentioned need to be issued in a terminal, as root. To open a terminal just run a program like KDE's "konsole". To get root permissions, run "su -" followed by the root password when prompted.

Linux is a true multi-user operating system. Even if you are the only physical user, there are still many different users on an average Linux box. These include dedicated users which are used to keep software like print-servers operating with limited access to files. Sometimes you will need to get yourself administrator ("root") user permissions. This is done either by logging on as "root" or by logging on as your normla user, and running certain programs as root (the latter is preferred, since you are less likely to destroy your computer). Getting root permissions ina terminal I explained previously, and from there you can run graphical programs like "konqueror" if you are unfamiliar with using the command-line.

You should NOT run as root for day-to-day use though, since nothing will try and stop you from deleting or modifying important files, and generally breaking stuff.

So, to get that file into /usr/src you will need to open a terminal (like konsole) run "su -" and then run "konqueror" or whichever program you use for file-management. You should be able to drag from a non-root window to a root-window with no probs (it certainly seems to work in Konqueror in Mandriva 2006). You can then use the instructions in the topic I linked to (or you could do it first, it isnt important, since the problems are probably unrelated), to give us a bit more info about what's going on with the USB drive.

Good luck! smile.gif

Well I partly got it fixed, but not all the way. I was able to move the file to the /src directory and followed the directions in the readme file I was given and I ran the command # tar zwvf pcmcia-cs-3.1.34.tar.gz and have an error that I must specifcy one of the '-acdtrux' options. Here is what the directions read as:

1. Download the "pcmcia-cs-3.1.xx.tar.gz" into the
"/usr/src" directory.
PS: xx is the latest version of the package

2. Run the following commands:

#cd /usr/src
#tar zxvf pcmcia-cs-3.1.xx.tar.gz
#cd pcmcia-cs-3.1.xx
#./Configure or make config
#make all
#make install

Above it also mentions using config in the kernel.

To use the drivers
provided by standalone PCMCIA Card Services package, configure the kernel
with CONFIG_PCMCIA ("CardBus support") Disabled, then re-compile the kernel
with the new configurations.

Not sure if this will help? But this is what I'm trying to do.

It was able to find my thumb drive, but how do you access the files or save files into it?
Assuming that your thumb drive was linked to device "/dev/sda" you can "mount" it (add it into the filesystem) using "mount -t vfat /dev/sda1 /mnt/usbdrive"

You need to make the directory /mnt/usbdrive first though. sda1 means the first partition on sda

I'm not too hot on compiling kernels on Fedora, so hopefully someone else can give some pointers with regard to that. Bascially, you just need to extract the file that you moved into /usr/src. Again, you cna use a graphical tool like "ark" to do it for you.

In regards to installing the pcmcia card, I'm able to extract the file inso /usr/src and able to perform a few commands until I get to 'make config' or './Configure'

I get an error that reads Your system does not have 'gcc' installed. Install a normal set of linux development tools and try again.

Also with the usb device, I follow the directions to the link you provided and I get stuck at step 5. The cursor goes away and it's like I'm typing on a word processing sheet. I also get an error message when I input the 'lsmod' or 'lsusb' command. Says not such command exists.

I was able to create a directory called /mnt/usb and use the command you gave me, but nothing is showing up.
You need to isntall a compiler (it's called gcc) - Should be listed under "development tools" in the fedora software manager. Otherwise just run "yum install gcc"

You need to press ctrl-c to exit the tail command before you can run any others. You might need to make sure that you're root before running lsmod or lspci - If it still doesnt work then just check that theyre typed in all lowercase and spelled correctly, I havent come across a system where they werent installed, but I suppose it is possible that they're not.

I was able to find files under sourceforge for gcc and burned it onto a cd, but can't figure out how to install it?

I also tried to run the lsmod or lsusb and still recieve an error that says command not found. I don't believe I have the full version, I have a publsiher's edition that came with a book, and if I don't have that command, is there a way to download it or try something different?
Not sure if this will help, but I can run the dmesg command and it lists my usb device, the model, size, sda1, etc.
*update* sorry for writing for a third time. I was able to access the folder /mnt/usbdrive and it displayed all my documents eventhough they are in a word document. At least I can transfer files I need ito my usb drive nstead of downloading it to a cdrom. Apparently I didn't need those commands I was trying to use.

I still need help figuring out how to install files from a cdrom and where to install it to. It will make things much easier once I get those drivers from my ethernet card installed so I can download files directly from the internet.
CDs should be automounted to /media/cdrom or /mnt/cdrom - From then on you can just use it like you would use any other device.

If you want to isntalla packages that are part of the Fedora distribution, then you can use the tool supplied (I forget what it's called) to do so, and it will prompt you for the relevant media.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.