Help - Search - Members - Calendar
Full Version: Boot Error - fsck.ext2
Linuxhelp > Support > Technical Support
BTB
When I goto boot RHEL4 on a demo laptop I get the following error:
fsck.ext2 is a directory while trying to open Failed

Restarting does not work.

I have tried fsck on the drive and e2fsck as well but I get clean on the file system. Dont know much about this so any detailed help would be appreaciated
Thanks
BTB
Termina
That's strange; does it say something after 'while tryping to open' that you omitted? You usually get that error when you try running fsck on a folder instead of a block device. (ie, /mnt/hda1 might be mounted, but you want to run it on /dev/hda1 not /mnt/hda1)

Is there anything about your filesystem we need to know? Is it compressed, etc.

Does this stop you from getting into linux?

Do you have something set up in system startup that is using fsck.ext2?

Does it do this everytime you boot?
BTB
yes it does it on every boot.

I cant get past this error. If I hit CTRL D to continue it unmounts the file systems and restarts back to the same error.
it says an error occured during the file system check
dropping you to a shell; the system will reboot
when you leave the shell

or if I type in the root password I am brought to
KDSKBENT: Invalid argument
failed to bind key 255 to value 976

(repair filesystem) 1 #

I have tried different variations of fsck and e2fsck but they come out clean?

Not sure
any ideas
Termina
Boot up a live CD, and find 'unicode_start' (in /bin or /usr/bin)

Remove the line that starts with: "dumpkeys | loadkeys "

Reboot, and see if that fixes it. (That should atleast fix the problem with logging in with your root password)

As for your other problem, what run level do you see in /etc/inittab?

Check out /etc/rc#.d (where # is your run level) and give us the output of 'ls'.

Perhaps there is a weird script in there causing problems /w fsck.

There is NO reason why fsck should be running every time you boot, if you've already run fsck and got a clean bill of health. Where did you run fsck from, though?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.