Help - Search - Members - Calendar
Full Version: File System Access Rights
Linuxhelp > Support > Technical Support
I just installed linux on my machine: a Caldera release. It's a lot of fun, i definitely appreciate having it. But i'm having a few problems. Here's one.
I have two physical drives, and I use (and have used for some time, back when i ran windows) one of them to store a large music collection. I kept it intact when i converted to Linux, and now i find that it has been mounted as a read-only file system, so i can only play music, not organize or add to it. as i understand, i cannot use chmod or chown to alter this, and have found no suitable way to remedy my problem.
any idas?
Okay, first off, is the second physical disk (the one holding your music collection) formatted with fat32 or with NTFS? Or is it a linux-formatted filesystem?

The reason:

FAT32 and Linux filesystems are fine, you should be able to read-write to these without any trouble. NTFS is a different deal. The NTFS filesystem has yet to be fully figured out, you are able to read from it fine, however, writing will not work. The linux kernel does include code for this, but it is extreamly unstable and you risk loosing all data on the drive by using it.

What to do:

...if it is NTFS, then you have two choices. The first choice is to leave it and settle for only reading and no writing. The second choice is to copy all your music files to another partition then format that drive to a linux filesystem with mkfs and copy all your files back over. If you still have windows instaled somewhere, or would still like to make it readable to windows for some time in the future, then instead of formating for linux, you can use a dos bootdisk, and format the drive as fat32.

...if it is FAT32 or Linux, then you can setup your /etc/fstab file to mount the filesystem with read-write access. Instead of going into specifics on this, I would suggest that you read the man page for mount with "man mount" and check out the fat32 section for parameters on mounting the drive with different permissions
Cool. Thanks. It definitely isn't linux... How do I tell which it is?

If you issue the command "fdisk -l" (that's a lower case L) it may tell you what filesystem is on that partition.
Ok. I tried, and I guess i don't have fdisk. Can I get it?

i've also been having problems with a shell script i've been writing - i've found that my shell isn't saving the exit status of programs as $status. can i set status to have the correct values?

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.