Help - Search - Members - Calendar
Full Version: postfix, mysql,courier-imap on fedora 5
Linuxhelp > Support > Technical Support
mmoor
Okay i need help smile.gif
Buyed 3 books but still dont work..

I have:
mysql v4.1.19 8Server, client, bench, etc)
postfix v2.2.10

make -f Makefile.ini makefiles 'CCARGS=-DHS_MYSQL -I/usr/lib/include' 'AUXLIB=-L/usr/lib/mysql -lmysqlclient -ls -lm'
make
make install

<postconf -m

dosent list mysql

try to install courier-imap 1.4.4
says faild on authmysql

Any help is welcome
Termina
You didn't give us much information, but I'll try to help.

Are you trying to set up postfix to use virtual users from mysql?

What have you added to main.cf? (can you upload it somewhere, and give us a link?)

Do you have virtual_alias_maps and virtual_mailbox_* set up correctly?

Also, did you make sure authdameonrc is using 'authmysql'? Is courier-authmysql even installed?

Some more information would be much more helpful...
mmoor
got postfix compiled with mysql.. that works now..

but still no success on courier-imap-1.5.3

call
./configure --with-mysql-libs=/usr/lib/mysql4/mysql --with-mysql-includes=/usr/include/mysql4/mysql --with-authmysql

[..]
checking for mysql_config... (cached) /usr/bin/mysql_config
checking for mysql_connect... (cached) no
configure: error: --with-authmysql specifed but no mysqlclient.so
configure: error: ./configure failed for authlib

And there configure stops.
--------
I have installed:
mysql server 4.1.19-Standart-log
mysql client 5.1.7
mysqlclient3, mysqlclient4, both including devel.
courier-authlib-mysql 0.58-1.5.i386.
mysql-bench 4.1.19-0
mysql-devel 4.1.19
mysql-shared 4.1.19
mysql-shared-standart 4.1.19
mysql-standart-debuginfo 4.1.19
Termina
That's strange, that it cannot find mysqlclient.so. Have you tried updatedb && locate mysqlclient.so?

You may just need to copy it to the current dir, or run ldconfig.

Is there a reason you're compiling instead of using rebuilt packages? What distro do you use?
mmoor
Nope i dont think there is any reason why i compile ? But since im a complet noob in linux my 4 day i fumble on it. thats my a good question. smile.gif

Fedora 5, but could not find any rpm packages for fedora, and have to say soon i lose my marbeles smile.gif

Yep no mysqlclient.so not on the entry drive..
just
libmysqlclient_r.so
libmysqlclient_14_r.so
and stuff like that
Termina
Chances are you compiled mysql wrong, then. sad.gif

I really suggest you find a good mirror, after you 'make uninstall' all your current stuff.

Using recompiled binaries makes it much easier to install and upgrade.

Remember: If you compile, you're going to have to recompile everytime you want to upgrade.
mmoor
yepers.. well gave up..

Now i have postfix runing and vm-pop3d .. that works great..

Dont think it was mysql, becouse websites what using mysql where runing great.
mmoor
talked to erlay.. vm-pop is goofy also.

Cant pick up mail via netscape mail, via outlock it works until today.
Now I get an error: (The RETR command did not succed. Error retrieving a message. Mail server xx.xx.xx responded: libc detected *** vm-pop3d: munmap_chunk(): invalid pointer: 0x095663400 ***)

After reinstall new.. I get in netscape mail. (Folders get processed. pls wait until this is done to get emails.)

Since im a complet newbie, another question is there somewhere a easy to install and configure pop server out what handels virtual mailboxes ?
Termina
Here's a great article about the kind of set up you want.

It's for Debian stable, BTW.

http://workaround.org/articles/ispmail-sarge/
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.