Help - Search - Members - Calendar
Full Version: crontab permission
Linuxhelp > Support > Technical Support
adamwer
Hi
System: PLD Linux 2.6.8, vixie-cron. While installing gnats I encountered the following:

[root@sierra ~]# cd /home/users/gnats
[root@sierra gnats]# su gnats
[gnats@sierra ~]$ ls -altr
total 28
...
-rw-r--r-- 1 gnats users 64 May 9 15:28 .mycron
...
[gnats@sierra ~]$ crontab .mycron
You (gnats) are not allowed to use this program (crontab)
See crontab(1) for more information
[gnats@sierra ~]$

I checked the files below several times:
/etc/cron/cron.allow
/etc/cron/cron.deny
Additionaly I created (with the same attributes):
/etc/cron/at.allow
/var/spool/cron/at.allow
/var/spool/cron/cron.allow

Finally I tried:
chmod a+rwx /etc/cron.d/crontab

Still the same error.
I will appreciate any hint.

Cheers
Adam
Termina
That's pretty strange. Here are some ideas.

Does plain old 'crontab -e' give you that same error?

You say you checked /etc/cron.allow/deny; are they empty? I believe that, if cron.allow is created, users that want to use crontab MUST be listed there.

Perhaps something in there is causing the problem, could you show us the contents?

I see you changed the permission of /etc/cron.d/crontab, but have you done the same with .mycron?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.