I currently have a dual boot xp/Suse 9.3 machine connected to a d-link adsl modem router. I am having major problems trying to get Yast, and gaim to connect and/or update over the internet. Firefox works just fine, although i did have to disable IPv6 by default. Gaim in windows works just fine as does any other equivalent app eg windows update. I have also tried various different distros including Knoppix, Debian, and even Gentoo. All have problems when thier respective update tools attempt to connect to the internet. Again though I can still browse just fine with links, firefox, konquerer etc. I would have initially thought the router to be at fault but considering that msn messenger, gaim and all other windows apps work fine (presumably using the same ports and protocols) I am starting to think there is something i need to change in my linux configuration (given that nothing in windows has problems). I have however also tried both static addressing and dhcp plus numerous port forwarding configurations. This problem is exactly the same if i use ra0 or eth0 however dial up works fine??????? As much of my time online is spent using IM clients this is probably the only obstacle to me ditching xp completley. Any help would be greatly appreciated.

Many thanks,
John Ward.