Help - Search - Members - Calendar
Full Version: Error booting after upgrading Kernel
Linuxhelp > Support > Technical Support
scratched
I'm new to linux and I just installed ubuntu 5.10 on an external hard drive. I got it to run without a hitch, then I upgraded to the latest kernel and tried restarting. I got to the GRUB screen, selected ubuntu, and then I got this error:

CODE
root (hd1,1)
Filesystem type unknown, partition type 0x7
kernel /boot/vmlinuz-2.6.12-10-386 root=/dev/sda2 ro quiet splash

Error 17: Cannont Mount Selected partition.


I have ubuntu installed on the second partition of my USB hard drive so the root is in (hd1,1) (at least I think it is. like I said I'm new to linux so this is somewhat foreign to me), and I reinstalled GRUB since it looked like other people have had that problem, but as far as I can tell, I re-installed grub properly and it didn't fix it. I can boot to windows, and I can boot with a knoppix or ubunutu live CD. The old kernel is still listed in GRUB and I've tried selecting that but I get the same error.

Does anyone know what this problem is and how I can fix it? I'm a newbie when it comes to linux so I really have no idea what the problem is.
Termina
When you upgrade the kernel with Ubuntu, it should have added a new entry in grub.

Use the Ubuntu Live CD, mount your partition, and make sure /boot/vmlinuz-2.6.12-10-386 exists
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.