Help - Search - Members - Calendar
Full Version: mounting an old rootfs
Linuxhelp > Support > Technical Support
noone99
Hello,
I am having a problem. I have linux installed but I can no longer get into it. I tried running off a live CD, but I don't know how i can mount the old rootfs so I can back up all my old files before I do a clean install. I did mount the HDD and I can see the rootfs, but I can't browse through it. Could someone please help me. If there is another way to retrieve the files that could be a good option too.

Also the distro I am using is Xebian off an xbox. What happened is that I swapped the HDD into a newer xbox and the video drivers don't work and for whatever reason it doesn't filly boot so I can't ssh into the box.

Thank you very much
michaelk
What are the error messages?
noone99
Well, I don't have any error messages when I run linux off the cd, I just don't know how I can mount a filing system from the installed distro while running off the cd. ZWhen I try to boot the installed linux, It goes through the usual checks, then when it tries to boot x, the screen goes black because it was installed on an old xbox with different a video driver. If there is a key sequence that I can press to keep from loading the gui, then I suppose I could ftp my files to my other computer and then reinstall xebian.
michaelk
The steps to boot without a GUI depends on the bootloader. Are you using lilo or grub? Mounting from the live CD should be fairly straight forward if you know the partition that you are trying access and the type of filesystem. So in a console window:

mount -t fs /dev/hdxy /mnt/drive (x = drive, y = partition # )

You might need to create a directory to use as a mount point.
mkdir /mnt/drive (example)
noone99
the boot loader.... that I'm not sure. I can mount the partition, but the actual rootfs is at /xebian/rootfs on hdc. I'm not familar enough yet with stuff like this when it comes to linux. I did mount the partition before seeking help by adding it to the fstab, but it mounts the partition then when I go to /F/xebian/rootfs I can't explore for say my old fstab, or other config files, it acts like a single file I can't open.
Also, I will see if I can find out which boot loader it is when I get home.

Another thing I find strange is that when I do boot into the installed linux, I can't access it remotely at all, but before when it was in the old xbox I set it up to automatically log in and load mythtv. Now for whatever reason when I ge the balck screen, I can't log in at all. My previous experience with video driver problems is that it will boot, I just can't see it on the TV or monitor!

Thanks alot for your help so far.
noone99
I did find that Xebian doesn't use grub or Lilo

"Bootloader: The boot process, partitioning schemes and file systems of the Xbox differ from a standard PC so common bootloaders (such as Grub or LILO) cannot be used. Instead, Xebian makes use of the common Xbox Linux bootloaders, which include xbeboot.xbe (http://cvs.xbox-linux.org/viewcvs.py/xbox-linux/xbeboot/) (a plain XBE bootloader), xromwell.xbe (the XBE version of Cromwell), and Cromwell (a flashable replacement firmware for the Xbox with a built-in Linux bootloader.)"

In my Xebian directory I have a file called linuxboot.cfg. When I view it this is what follows:

kernel vmlinuz
initrd initrd
append init=/linuxrc root=/dev/ram0 kbd-reset xbox=fatx_e:/debian ramdisk_blocksize=4096
xboxfb y
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.