Help - Search - Members - Calendar
Full Version: Linux console problem
Linuxhelp > Support > Technical Support
samuk81
I have installed Linux 8.0 in my system. Linux boots as normal I can login as root in Xserver but for some reason when I change to Linux console (Ctrl+Alr+F1) the console flickers and I hardly see anything. When the Xserver starts it just messes up the Linux console. Does anyone know how to solve this problem.

my laptop spec are:

Hardware spec

Processor: 1200 MHz
Memory: 640Mb
Video Card: Intel 82830MP Integrated Video
PCMCIA Controller: Texas Instruments PCI-1450
Display: Digital flat panel 1024x768
Hard Disk: 40Gb internal
Ethernet Card: 3COM 3C905CX-TX-M

Software spec

Linux Release: RedHat 8.0
Linux Kernel: 2.4.18-14 (default) + 2.4.25
Robert83
Hello

in /boot/grub/menu.lst

add vga=788 to the end of the kernel parameter line.

like this , your kernel version will differ , but I only put this here for you to see it visualy. You
only need to add vga=788 , reboot and see if console is okay now.

CODE
kernel /vmlinuz-2.6.9-22.0.2.EL ro root=LABEL=/1 vga=788


see this link also http://www.antlinux.com/pmwiki/pmwiki.php?...HowTos.VgaModes


Sincerely
Robert B
samuk81
Hi Robert,

Thank you so much for your email. I did exactly what you have told me in your email but that didn't solve my problem i still get the console to flicker. I have also added vga=773 in LILO.conf since i have installed LILO in my system.

Code

append="hda=ide-scsi root=LABEL=/ vga=773"

but it's just no luck. Any suggestions.

I'll be looking forwad for your reply.

thanks in advance

Sam
Hemant
I think, you are VESA emaluation right now...in your Linux box. You will get flicker, when you use VESA emaluation..what it means is your video card id not properly configured....

What i would suggest is, upgrade to a more latest version(by Linux-8.0, i think you mean Redhat-8.0, which is very old).
samuk81
Hi Hemant Kumar,

Thank you so much for your email. I am a Software engineer i have developed a software which can only be compiled under Linux RH7.3 and run under Linux RH8 it does not work under any other linux versions. If i upgrade to a new version of linux i won't get my software to run and getting it to run in Linux is just too much pain.

I am sure there is a way to get my console to work. Linux RH8 works perfectly its just the console. The console starts flickering as soon as the Xserver starts.

if anyone knows how to get around this problem then please do let me know.

thanks in advance

Sam
Termina
You may wish to install a fresh copy of RH9 (or something newer) to a spare partition and try compiling it on that system.

Is there a reason you can't update your program to include newer libraries, so it'll compile and run on newer systems?

Most programs I've come across didn't need much tweaking to compile under a newer linux distro.

Have you tried running the binary on another linux machine? Even if it complains about missing libraries, you can install older versions just so it'll work. smile.gif I've done that myself with a game server originally built for RH-7.3

Also, is it important that you use a virtual console? (Why not use a terminal in X?) Have you tried Ctrl+Alt+F2 (etc.)?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.