Help - Search - Members - Calendar
Full Version: Trying to install Firefox
Linuxhelp > Support > Technical Support
RuralTurtle
I'm trying to install Firefox from a RPM (firefox-0.8-3.0.rh8.dag.i386.rpm) on a RedHat 8.0 box. It comes up w/ an error that says:

Package Not Found

The following package could not be found on your system. Installation cannot continue until it is installed.

Package=libpthread.so.0(GLIBC_2.3.2)


How would I install this missing component? Would it be easier from the source; how would I 'make' it?

Thanks for your help.
Termina
Just downloading firefix from http://www.mozilla.com will leave you with a .tar.gz file that creates a directory with all the firefox binaries.
RuralTurtle
Yep, already tried that. When I run the binary, I get:

./firefox-bin: /lib/libpthread.so.0: version `GLIBC_2.3.2' not found (required by ./libnspr4.so)
Termina
You're using RedHat 8.0, so your glibc is going to be out of date. wink.gif

Is there a newer version in the RH8 repositories? Try using yum to install it, or download http://ftp.gnu.org/gnu/glibc/glibc-2.3.6.tar.gz and try installing it.

Best of luck!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.