Help - Search - Members - Calendar
Full Version: Ip-Passthrough and linux not getting along
Linuxhelp > Support > Technical Support
Kyle Katarn
Ok, here's the deal. I have a older linux system that I use as a server. I recently moved, and now I have aDSL rather than the cable I had before. Now, when I go into my dsl modem settings, the closest thing it has to DMZ is an "IP-Passthrough". So I set this up to point to my system, and now the system says it cannot get an IP address, and therefore cannot connect. I tried setting this up with a Windows system and it worked fine. I tried using another system as the server, same problem. I've tried a number of distro's, including Debian, Fedora Core 4, and VectorLinux. Same with all. Yet it works on Windows. I've tried 3 different machines. On all it was the same, Windows worked, Linux didn't. I've spent about 3 weeks trying to get this to work, so I would appreciate is someone who is more familar with this would help me.

Thanks,

Kyle Katarn
Jim
Alright, how are you trying to get an IP address? Are you using DHCP or are you trying to assing it staticly? Is your DLS modem a router too or is it only handing out one IP? Is it handing out the external IP, or an internal one. Do you need to register your MAC or something with your provider.

So this is the way I understand it. You have

QUOTE
WAN----------DLS Modem & Router -------------------- Server
                                                                |
                                                                |____________ Windows Machine

Your windows machine is getting an IP via DHCP but your server isn't. If you haven't tried setting up a static IP that would be my first step. I blame this problem on your router.
Kyle Katarn
It is DHCP, the modem/router assigns all addresses on my network. In the IP-Passthrough configuration page, I put in the MAC address of the server, and it assigns the WAN address to it via DHCP. This works fine if I have Windows running on the server, but if I have the exact same hardware and network configuration with Linux, it does not. That is why I don't see how it could be a problem with the router. I install Windows on the server, it works fine. I install Linux, it does not.
michaelk
How are you configuring the network in linux?
Are you selecting adsl, lan, cable etc..?

Typically a computer directly connected to an ADSL modem would use pppoe or pppoa with the IP address being assigned from the ISP. Did you enter your username and password in the modem?
Kyle Katarn
In Linux I set it up as a LAN. All my other systems connect to the same modem/router, get their internal IP's and work fine. All the username/password stuff is internal to the modem. I don't have it bridged to the server or anything. And it works fine with Windows right out of the box. It autoconfigures the LAN connection, uses DHCP and is given the WAN IP by the modem, and works perfectly. That's what I can't understand. Under Linux it works fine if I remove the passthrough; it gets an internal IP and works great. But when I turn the passthrough on, it won't accept it. It says it can't get an IP.
michaelk
Instead of LAN try using adsl connection.
Kyle Katarn
It really is not feasible for me to do so, because I have other computers on the network. From what I can tell, the problem has to lie somewhere in the linux OS, and I'm convinced it's just some setting somewhere that I know nothing about.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.