Help - Search - Members - Calendar
Full Version: FC4 and root password can not be recover
Linuxhelp > Support > Technical Support
zillah
I have got Linux FC4 , I forgot password for root.

How can I recover it through rescue CD1 (I did it through GRUB), but I am looking to do it through CD1

I used FC4 CD1 to boot PC in rescue mode

1- F5 for recue mode

2- Type in : rescue mode----press Enter.

2- chroot /mnt/sysimage

3- Sh-2.95b # passwd root,,,,the output was :
Passwd: system_u:system_r:anaconda_t is not authorized to change the password of root

4- I tried type in : passwd (with out word "root" see step 3)

Where is my mistake ?
Robert83
Hi,

So you remove that rescue cd, or whatever cd you have in there from the pc, reboot.

When the grub screen shows up you press a.

Then at the end of the kernel parameter you type 1.

For me this looked like this :

CODE
grub append> ro root=LABEL=/ vga=788


And the init level 1 version looks like this (this is what you want)
CODE
grub append> ro root=LABEL=/ vga=788 1


your line might be different ,but the point is you must add the 1 to the line.

Once the system boots up in single user mode where it asks for no password.

you type
CODE
passwd


and type in new password for root, then press ctrl-alt-del or type reboot

And don't forget this code smile.gif

Sincerely
Robert B
zillah
Thanks Robert83

I had done it through GRUB before I posted my thread here.

I am looking to know why it did not work through CD1 (i.e I am looking to do through CD1 not GRUB),,,,this is what I meant by :
QUOTE
How can I recover it through rescue CD1 (I did it through GRUB)---
DS2K3
An FC4 install disk is basically a LiveCD, with seperate users/groups to your isntalled system. It looks like the "anaconda" user (the one that the LiveCD runs as defualt) just doesn't have permission to modify an installed system's root password. If you followed official instructions, then they are most likely outdated. or just plain wrong.

D
zillah
QUOTE
If you followed official instructions, then they are most likely outdated

What did you mean here by official and outdated?
Jim
You can't change the password from a live CD when you chroot into the envirotment. The Federa Recovery CD is essentially a live CD.

What D is trying to say is if you got those instructions from Fedora (official) than they are either outdated (they worked at one time, but not now) or wrong.

In general the best way to reset a root password is to go into level 1 or single user mode (same thing) and reset it that way.
zillah
I rested the password I was able to login without any problem after reseting,,,after while (I have not used Linux PC for about 20 days) I came again,,,i could not login!!!

Can be there is something (some setting mistakenly I configured it when i installed FC4) changing the password ?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.