Help - Search - Members - Calendar
Full Version: Probleme With Linux -_-
Linuxhelp > Support > Technical Support
I just installed Linux Mandrake 10.1... ans i do not anderstand anything...
i know how to open rpm files... i've downloaded skype... but i dont know how to control the installation... now skype is somewhere in my comp lol ohmy.gif
and i dont know how to open .run , .bin and .tar.gz
srry for the double post and for my english xD
Sorry dude, I am not gonna give you a full linux tutorial. You have to ask specific questions. Here are some hints.

1) Google is your friend
2) If you want to know how to use a command run man command
3) README.txt is your friend

If you have a specific question then ask, but you can't just ask me to explain linux to you.
well... thx anyway... but do u know a good website to learn how to use Linux Mandrake... cause when i search on google ... it dont say anything about installing and .run etc... etc... etc... xD
well here, lets do a specific case then. So you're trying to install Skype? Which package did you download? I am pretty sure that Mandrake 10.1 is the same as Mandriva 10.1 so the Mandriva rpm should work for you. You simply need to download it, launch a terminal and fallow the instructions.

What specifically are you having trouble with, and where are you seeing the .run?
for skype it was easy ... i've just double cliked the rpm and it install itself... my only probleme is cause i dont know where it installed lol... but for wet (wolfenstein : ennemis territory) it a .run sad.gif and i dont kow how to use them...

(and yes Mandriva is the same... lol !! ... y 2 name ?)
Ya, I know mandriva is the same company as Mandrake, but I didn't know how the Mandrake 10.1 release was exactly the same as the mandriva 10.1 release, I guessed they were, but ...

Ok, Wolfenstein huh? Ok, dot runs, well I was thinking I have never dealt with a dot run but now I realize I have. dot run is simple, its just an exicutable its self. You just straight up run it.

First open a termianl, run su to become root. Second you need to make sure its taged by the system as ok to be exicuted, run chmod +x replacing with the actual name of the file. Then you just run it by typing ./ and away it will go.

You can do that with any file that has commands in it, or bash scripting. You could open a text file that has the lines
cd /
ls -lh | sort -n +4
cd ~
du -sh

Then chmod that file with the +x to make it exicutable, then run it with ./filename and it would run those four commands. So there is some good general linux info for you. Let me know if you run into problems installing Wolfenstein, I am guessing it wont be as easy as just running the script, but if it is, let me know that too. :-)
O ya, and you said you didn't know where skype is. Well, there should be short cuts to it in your menu, that part of what the rpms should have done.

If not, become root (above) and run locate skype that will tell you where it is, as long as your system is configured for locate, some aren't.

Its most likely in /usr/bin but not always.

You can launch in from the command line with some command, who knows what it is. Here is a good little trick for you. You can use <tab> to auto-complete at the command line. Just start typing and press tab and it will fill in the rest. Depending on how your system is configured if you press it ounce and it doesn't know yet, sometimes it wont complete, but if you press it twice, it should give you a list of options.

So start typing sky and it tab and see what you get. You should be able to run it from the command line. Then you can make a short cut to it ounce you know what command launches it. But I am guessing since its mandrake it somewhere in your menue.
YEA it work !!! thank you very much man !!
and yea thx again skype was in the /usr/bin but no shortcut in the menu sad.gif
anyway thx u again !!!
srry for this couble post sleep.gif
lol srry for boring u again... but i got another problem sleep.gif ...
i've download anothere program... to burn cd... and when a try to install it... (i've read the README but nothing talk about this problem...) it saying this message
[sam@localhost lmme-0.6.4]$ dir
aclocal.m4  configure    INSTALL      missing        refresh-autoconf  TODO
AUTHORS  install-sh  mkinstalldirs  src
ChangeLog    COPYING  NEWS  docs  README        symlink-fix
[sam@localhost lmme-0.6.4]$ ./configure
creating cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking for gcc... no
checking for cc... no
configure: error: no acceptable cc found in $PATH
[sam@localhost lmme-0.6.4]$
you don't have gcc installed, which is the basic compiler for making programs.

One of the nice things about Mandriva is it has a nice package managment system. Somewhere in the control panel, I am not entirely sure where anymore, there are options for adding/removing packages. Mandriva has packages for most of the software you could ever want.

It looks like you're trying to intsall lmme which is a messenger, not a burner. K3b is a great burner for linux if you need one of those. Look around in the menues for Mandriva's built in package managment system. Or look around on google for how to use it. You will find it very helpful. I know I did when I ran mandrake. Maybe I shoudl pop a new copy of Mandriva on my system again sometime.


I suppose I didn't really answer your question. Anyways, you're goin to need to find the package for gcc if you ever want to make programs from scratch. You can't compile it since you don't have a compiler.... see the problem? Thats why you need to find the package management too.
lol sleep.gif yea that was lmme, cause i've tryed to install 2 or 3 thing ^^
anyway for my package i just reinstalled everything and it work fine now !
now i got a last problem.... well.... for the moment sad.gif ...
i reinstalled Wolfenstein and i tryed to open it... i open it with ./et
and see what it said :
[root@localhost enemy-territory]# ./et
ET 2.60 linux-i386 Mar 10 2005
----- FS_Startup -----
Current search path:
/usr/local/games/enemy-territory/etmain/pak2.pk3 (22 files)
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (6 files)

3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
----- Client Initialization Complete -----
----- R_Init -----
...loading Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 1024x768
Using 4/4/4 Color bits, 16 depth, 0 stencil display.
GL_RENDERER: Mesa GLX Indirect

You are using software Mesa (no hardware acceleration)!
Driver DLL used:
If this is intentional, add
      "+set r_allowSoftwareGL 1"
to the command line when starting the game.
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 1024x768
Received signal 11, exiting...
[root@localhost enemy-territory]#

do u know what the problem ?

P.S. srry for boring u again with my problem
I am not exactly sure what the problem is. Try setting your display to 640x480 before launching Wolfenstein, it looks like its having trouble doing that automatically.

What programs did you install between the first time you installed Wolfenstein and it worked and now?
Mandrake/Mandriva used to have a set of turorials available - They started nice and simple, which was nice. This seems to be it:

Mandrake became Mandriva (it doesnt really have two names, it just has a new one) when Mandrakesoft acquired Connectiva.

thx... but it still dont work xD lol thanks u.. i'll try to find by myself ^^
ok.. i installed americas army ... and it work well... lol ... well.. tongue.gif just a problem ... some people said .. linux got less lag ... and ... i lag on the menu lol !! i think i dont detect my graphic card... do u know y ?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.