Help - Search - Members - Calendar
Full Version: Mounting Ntfs Partition
Linuxhelp > Support > Technical Support
redg
I have a dual boot WinXP/Debian machine, there are two NTFS partitions, one System which I don't need to mount and one Data which I'd like to mount automatically on Debian boot.

I've got it mounting, but the permissions are all messed up.

What are the correct options(not just permissions) I should put in etc/fstab to mount this drive read/write for all users, root doesn't need access, but I don't know if it is possible to allow users to access it without root having access?

Any tips would be appreciated.

redg
Jim
ok, a couple things. One, "root doesn't need access" by nature, if you give access to anything, you give it to root. That is the nature of root, it can go anywhere. Locking root out of things is almost impossible.

Second, that depends on who needs to access it. I mount my NTFS data right into my /home/jim directory because nobody else on the system needs access to it.

If everybody needs access then you should mount it to somwhere like /mnt/windows or something.

I would recomend an fstab entry, this is what one of mine looks like.

CODE
/dev/hda1               /home/jim/.windows      auto            noatime,users,umask=000      0 0


I use auto just because, well I do, natime is a performance thing, users allows it to be mounted by users but since it is mounted at boot that is kind of not needed, umask=000 makes it readable by everybody, but since its in my home directory I am the only one who can get to it. The last two zeros are maintence things and they should be left at zero because ntfs doesn't support these options.
redg
Thanks Jim,

That worked after a slight tweak of the syntax.

"/dev/hda1 /home/jim/.windows auto noatime,users,umask=000 0 0"

/dev/hda1 /home/jim/.windows auto,noatime,users,umask=000 0 0

I got an error when auto was in a seperate list, this may be something to do with my version of mount??? Don't know.


Cheers redg
redg
Sorry my mistake,

I still had ntfs in my fstab entry, of-course auto replaces this, so you were spot on.

/dev/hda1 /home/jim/.windows auto noatime,users,umask=000 0 0

redg
Jim
I just hope you aren't mounting it to /home/jim/.windows unless your name is jim.
redg
Well trying to figure out how to slot my name into your code would have thrown me, so I decided it would be easier to change my name to
William by depol! unsure.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.