Help - Search - Members - Calendar
Full Version: Devise Reset
Linuxhelp > Support > Hardware Support
sir
Device is busy - but there is no obvious task for it.
I know there is some sort of command - but d'not remember it.
HELP please, I gonna be killed fot not knowing it.
=_))
michaelk
Information please... what device?
sir
ThanXX for aswering..
The problem is: Linux based sys sees the tape drives.
U know the big things operating with magneto tapes.
But while commensing some data aquiring from it - reports that there are no data on the tape - but for shore theree are.
Mainly question is the same:
HOW TO RESET THE TAPEDRIVE.
i know there sort of the command like
tapeopt or something but not shure for that....
Rgrds.
michaelk
Still need some information:
Is the something that you have done in the past but it is not working now?
What type of tape drive i.e. make / model and how does it interface to the PC? IDE, SCSI etc.
What is the application your using to reterive data from tape?
Do you know the device ID of the tape drive? i.e /dev/st0 etc.

Assuming a SCSI drive what is the output of the following command:
mt -f /dev/st0 status

How about just pushing the tape eject button on the drive and reinserting the tape.
sir
-Do you know the device ID of the tape drive? i.e /dev/st0 etc.
Exactly it is. It's scsi tape drive

- Assuming a SCSI drive what is the output of the following command:
- mt -f /dev/st0 status
Yes, it's the most common command to deal with the tapes, but it's still should be another on.
I'm not that goog at programming, but take a look at -st- man, there would be a MTRESET command,
I just wonder how to run it with mt.
And shurely I'v put in _mt -f /dev/st0 status_ wich give the msg: device busy

-How about just pushing the tape eject button on the drive and reinserting the tape.
Yeah you could even reset the drive manually by pressing on/off butt, but there should be more gentle way to do it from software.
=_)
michaelk
My basic tools are dd, tar and mt. There appears to be some other tools and library functions but googling has not found anything.

You might have a hardware problem where either the tape drive or the tape is malfunctioning. In this case there isn't anything gentle...
sir
Anyway THANX a lot for taking time.
I'll post any new info if I'll only have one.
But the problem is definetly not in Hardware -
Bcourse I figured that there is one process stil controlling the drive, while not using it.
It just grabbed tape drive by the mistake of the operator - so i have to wait till the end of this process.
So there should be definetly some memory buffer operation.
I now for shure that there are sort of that kind commands for the thermoprinter - oyo,
When you can reset it's buffer memory.
Cheers.
And let the Great Pinguin save your soul. =_))
michaelk
I am courious as to what process is controller the tape drive. You should be able to kill the process via the kill or killall command.
sir
Huh, That was the main reason to make it gently - becourse I couldn't kill the process.
Anyway the solvation came from the process itself it just has ended and finally freed the drive, and it's now working ok.
But I'm still waiting for the comments from my friends, course I know for shure there is some special command.
Cheers.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.