Help - Search - Members - Calendar
Full Version: I Need Help Please$@!$##@$
Linuxhelp > Support > Technical Support
My problem may sound quite simple for the experienced linux user but I am not... I am in need of some advice. I have 2 physical eth cards in one machine cabled to 2 linksys routers one for each eth I am trying to get my vsftpd working on one provider and my httpd working on the other router both have there own static ip... I have the address for the cards at for my ftp server and for my httpd... I have set the line in the vsftpd.conf to listen_address= but it still cant be reached.. however I can change the gateway on the ftp router to
instead of whhich is the same as my httpd router gateway and the ftp server begins to be seen and works... but my httpd server can no longer be found..

if someone could help please
my route is as follows

destination gateway genmask flags metric ref use iface * u 0 0 0 eth0 * u 0 0 0 eth1 * u 0 0 0 eth1
default ug 0 0 0 eth0
Change one of your ethernet card / router subnet to something other then 192.168.1.x i.e. 192.168.2.x
ok tried this,, Changed the linksys router configuration to
set my eth1 on opened up the port to see on the ftp port 21 set my vsftpd.conf to listen_address= once again the ftp would work but my httpd quit working.... I could view my web pages this time from withen my local domain. but when i tried to view them from a remote pc it would not allow me to.... I did notice that now when I log on to the Internet from the linux box it is pulling the static ip from my eth1 card and no longer my eth0 when this was changed...

I did check all my firewall settings and even disabled them while i was testing

anymore suggestions
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.