Help - Search - Members - Calendar
Full Version: Apache Serving Internally But Not Externally
Linuxhelp > Support > Technical Support
Neuffy
Ok, I'm running Kubuntu, with apache installed.
Everything's setup, and when I type "http://myip" it comes up with my
homepage. When I type "http://www.neuffy.com" it comes up with my
homepage.

But when I type "www.neuffy.com" on my Win2k box beside it, I get "The
operation timed out..." Same with a computer external to my network.

The kubuntu box is pinging correctly.
The kubuntu box has regular web access.

with
netstat -ntld
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN

I've tried binding it to my ip, I've tried binding it to nothing.
When I bind it to my ip, the netstat gives it being bound to the local
address (ip) but still 0.0.0.0:* for the external? Is this a problem.

Any suggestions?
Thanks.
Jim
check your firewall settings. I also must say that if you are actually planing on running a web server kubunut or ubuntu for that matter isn't the best choice.

But to fix your problem I would start by checking the firewall settings. You can also try to telnet in on 80 to see if you can even get to the box, that will tell you if the port is being blocked or not.
Neuffy
Ah....what firewall?

In any case, the computer's not primarily a webserver. It's a general usage box that will be serving a very small website to a very small group of people.
Jim
Alright, then thats not such a big problem, runnig Kubuntu I mean. I am pretty sure Ubuntu ships with a firewall, but I don't know where the controls for it are. I am not very good with Ubuntu, I also think its one of the worst distros out right now, but you can read my rants on that elseware in the forum. Try this from another machine

telnet www.nueffy.com 80

and see what it kicks back.
Neuffy
"Connecting To www.neuffy.com...Could not open a connection to host on port 80 : Connect failed"
Same with ip.

Hm...something's odd here.
Could I have killed something important when I killed ipv6/tcp6 to unlock port 80 for apache binding?
On a side note, I still can't make it see either the Win2k or the Win98 machines, or they it. No interfacing between each other, despite much alteration and manipulation of the samba and local network settings.

From what I've found, Kubuntu shouldn't come with a firewall....only thing in the control center linked with the word firewall is the proxy (which is not being used).

I'm pretty close to just finding another distro and reinstalling. You're right, Kubuntu is pretty messed up. Ubuntu's a little better, from what I've seen, but still messed up.

Thanks for the suggestions.
Jim
Well before you go and do that we should address the issue that the boxes can't see eachother. I was under the impression that you were able to ping all the boxes from eachother, but if that isn't the case then something else is very wrong.

Explain to me how you have them set up, like are they all behind the same router, or different routers or anything like that. If the ubuntu box is behind a router then you will have to forward port 80 on the router to to the box otherwise the router won't know what to do with the incoming 80 request. If you need help doing any of these you will have to be more specific about what you have.
Neuffy
Alright.

All boxes are attached to a switch, which is attached to a DSL modem. Win2k and Linux have ips. Win98 is proxied through the Win2k box. All have internet access. Win2k and Linux can ping each other. A computer external to the network computer can ping Win2k and Linux. Win98 not tested for pinging.

Win2k and Win98 can network share. Linux cannot see Win2k or Win98's network shares. Win2k nor Win98 can see Linux's network shares.

Thanks.
Jim
Well seeing the network shares is a whole different bag of cats than the boxes just seeing eachother or being able to access the web page through apache.

I am rather confused. The computer is listening on port 80 (and no it isn't a problem to have it listening on 80 for both your local and external IPs). But for some reason the computer isn't accepting incomming connections on 80. I will keep digging around but there is something here we aren't seeing.
Diod
Having the same problem. I can go localhost, but when im on a network computer it doesnt load my site.
Jim
Are you using Kubuntu as well?
Diod
I am using ubuntu, but with the KDE desktop installed seperatly(i like KDE more and didnt know kubuntu existed)
Jim
Maybe if I have time this weekend I will install a copy of Ubuntu again and see if I can figure out where the problem lies. My best advice to you guys is to just get a better distro, one that is more well rounded and less user guarded.
Diod
I dont think this has something to do with the OS we are using.
I had the same problem with windows xp a couple of months ago.
I think its more of a firewall/network problem but i cant find the solution.
Neuffy
Yeah, I think I'll do that. Any suggestions? All I want is really just standard webbrowsing/wp, minor webserver and perhaps wine~ish setup.

Thanks.
Jim
I really doubt its WindowsXP, if windows can get to google then it should be able to get to your site. I do still think that it might be a problem with the hardware inbetween your windows boxes at the ubuntu machine, but I can't much help you with that. You can use trace route to make sure its going exactly where you think it is and check each step of the way for blocking port 80. But I will still see if I can find some time to get Ubuntu installed again and give it a shot.
Diod
Yeah, i dont think its WinXP either, i think its either a firewall or router.
DS2K3
Some routers are funny about letting you access a computer on the private network, using the router's public IP address. eg, I can use "home.richardgomer.co.uk" from otuside, but if I try it from inside my network, the router doesnt forward the port and it tries to serve the router-admin page. So, using the domain name might be confusing the router (I get around it here by adding the domains that would resolve to my network into my shosts file, and point them at the computer that they would be forwarded to).

D
Jim
Ya, to bad Windows lacks the ability to do host files. I have never had that problem with my routers, but I guess I have heard of it, but only on ubber cheap home gateways. Never on decent stuff.
Diod
When i take a look at the Routing Table on my router it says:

Device Info -- Route

Flags: U - up, ! - reject, G - gateway, H - host, R - reinstate
D - dynamic (redirect), M - modified (redirect).

Destination Gateway Subnet Mask Flag Metric Interface
80.200.92.1 0.0.0.0 255.255.255.255 UH 0 ppp41
192.168.1.0 0.0.0.0 255.255.255.0 U 0 br0
0.0.0.0 80.200.92.1 0.0.0.0 UG 0 ppp41

And when i look at my routers ARP table it says

Device Info -- ARP

IP address Flags HW Address Device
192.168.1.12 Complete 00:11:09:E7:C5:06 br0

Whats an ARP table?
DS2K3
Windows DOES have the ability to use a hosts file smile.gif ('98 does anyway). There should be a "hosts.sam" file somehwere, which is just a sample file but hows the syntax (it's basically the same as the linux equivalent though).

D
Neuffy
Well, I haven't fixed it.

But I have discovered one thing: periodic time outs on pings. It sometimes pings, sometimes won't. I have no idea why. I'm getting ~<25% loss. (Just tried pinging it a few times from school.)

And yeah, kubuntu is basically just ubuntu+kde although a few commands and interfaces are changed.
chrisw
windows 2000 and windows xp have the ability to use host files...

use the the hosts file...i dont use the hosts.sam file...of course there might
not be one..but then windows 98 may use the hosts.sam file...

i think the hosts file for 98 is in c:\windows

path to hosts file in xp:

"C:\WINDOWS\system32\drivers\etc"

path to hosts file in 2k:

"C:\WINNT\system32\drivers\etc"
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.