Help - Search - Members - Calendar
Full Version: Reiserfs And 200gb Wd Caviar Don't Like Each Other
Linuxhelp > Support > Technical Support
pdiprete
Actually, this is blocking my install, and I'm frustrated.

The system is old, a Compaq Deskpro EN P600 with BIOS dated 8/22/1999. It has support for drives "larger than 64 GB". It's the latest BIOS available.

The system (only) disk is a 200GB WD Caviar EIDE. The BIOS reports only 128GB (ok, 137000000 bytes give or take...I remember when everything was to the power of 2).

Installing SUSE 10.0, YAST craps out after making the filesystem (error -3003):
"Storage modifications failed
system error code was -3003
failure occured during the following
mounting /dev/hda2 to /
mount -t reiserfs /dev/hda2 /
mount: wrong fstype, bad option...

I booted "rescue" and "successfully" partitioned the drive (sfdisk) and made a new filesystem (mkfs.reiserfs ...) without error.

Only the newly minted fileystem won't mount and fails fsck:
reiserfs.open: the reiserfs superblock cannot be found on /dev/hda3 (yes, different partition this time)

So, I'm thinking it's related to being a drive larger than 128 GB, but it's tantalizing close to working, which is the frustrating part. How do I get this to work?

I've tried using (very) small partitions to stay under the 128 GB limit, but that didn't work. I've also tried the "lesser" filesystems (xfs, ext2, ext3) with similar results.

All help welcomed!
Jim
Ya, when they say "larger that 64 GB" what they mean to say was "larger than 64 GB and smaller than what we think drives will grow to any time soon" I know its BS, but you are hitting that wall at 128 GB.

Problem is that I don't know how you will be able to get it to work. Any file system needs to be able to see the beginning and end of a drive, and your drive ends after your system is being told it should end. I don't know that you will ever get it to work, but long story short, I don't have an answer.
DS2K3
Some hard disks can be set to report their capacity at less than it actually is using a jumper. Havea look at the manufacturers website, or maybe send them ann email to see if it's possible.

D
Robert83
Hi,

I have a old compaq p2 300 mhz running a 120GB hdd and it only saw 50GB of it when installing , this is CentOS 3.x.

What I did was ... I booted up with the bootcd on a clean disk (no filesystem no nothing), and I've let centos partition it... and altought bios still sees 50GB, CentOS 3.x works for almost a year and sees it as 120GB (since then I've added another 120GB it works!).

Try this if you haven't... partition during installation (and with clean hd, NO filesystem).

Sincerely
Robert B

ps.: once linux is booted, it can see how big your hard drive is, even if your bios can't.

note !!!! my /boot is on seperate 100MB partition at the start of the drive... !!!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.