Help - Search - Members - Calendar
Full Version: Laptop Crash
Linuxhelp > Support > Technical Support
ghrueff
I am trying to do an install of linux on my Compaq Presario 2175 US. I have tried Mandriva 2005 LE, slackware 10.2, and debian 3.1. They can all install fine but then while I am using them they will suddenly crash. At first I thought I had problems with the power, but I have been vigilantly keeping track to make sure the cord doesn't have a loose connection and still the OS's crash. In Mandriva, the crashs occur with or without acp turned on. My best guess is that the CPU is being run at full power when it doesn't need to be and that causes it to overheat and eventually crash, but I don't know for certain. If anyone has any idea about why this is happening or how to fix it, please help.

Sincerely,
ghrueff
DS2K3
What do you mean by crash? Does it just stop respondin or does it switch off or reboot?

Can you provide the output of "dmesg" since it might contain info about any hardware problems. It might also be caused by faulty RAM, so try running a "memtest" program (often available as a boot option on install CDs) or swapping it with another one.

D
ghrueff
By crash I mean that it turns itself off.

I ran dmesg and have the output but it is a couple hundred lines long so I don't want to paste into this message directly. I don't see anyway to attach a file so I will try to set it up as a webpage and give a link to it when it is ready.

Memory testing proved to be interesting. There were two 256 MB DIMMs and two RAM slots on the motherboard. I tried running memtest from the Mandriva install CD and it would turn itself off during test seven. I then tried all four possible ways of placing one of the two DIMMs into one of the two slots. Each time I ran memtest and each time, all the tests were successfully completed without errors. Of course the amount of time that the computer took to run memtest on one DIMM was about half of that used to run two DIMMs. The point during test seven that it failed with both memory units installed was at about 65% completion of the full battery of tests.

I also received advice to configure lilo for a noapic boot of Mandriva. It hasn't been long enough since I did that to see if it helped.

Sincerely,
ghrueff
DS2K3
There might be compatability issues between your RAM chips - Sometimes running chips of different speeds can cause issues. Are the chips identical?

It might also be caused by your power supply, the extra RAM might just push it over the edge. Is it all original hardware, or have you upgraded and parts of the system?

D
ghrueff
All of the hardware is original. So both RAM chips are Samsung, 256 MB, PC2100, and 2.5V.

There are other symptoms with the power supply. Two things, first, the battery is not detected and second, when turning the computer off, the shutdown script runs all the way until the shutdown signal is sent at which point the computer becomes unresponsive, but still on.

As far as the noapic setting, it has now turned itselft off twice while using that setting, so that doesn't seem to be the culprit.

Here is the link to the output from dmesg
dmesg output

Thanks for all the help DS2K3.

Sincerely,
Gordon H. Rueff
Robert83
Hi,

please turn of the following (see if it helps)

apmd (used for monitoring batery status)


Sincerely
Robert B
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.