I just got some wireless cards from best buy(belkin F5D6001 PCI)
(if you run linux DO NOT BUY THEESE CARDS!!!!) and I put one in a Mandrake 9 box,which I use to NAT my cable modem.
Iim gonna be verbose in case any of this might help someone else)

modprobe orinoco_pci
iwconfig mode Ad-hoc
iwconfig essid cha0snet
iwconfig channel 1
iwconfig rate 11Mb
ifconfig eth2 10.0.0.1

nano /etc/sysconfig/dhcp
(add eth2 to list of interfaces)
nano /etc/dhcp/dhcp.conf
(add subnet declaration etc...)
/etc/init.d/dhcp restart

put another card in win98 box boot it up it dhcp's 10.0.0.2

now i can see the smb shares of every box on the lan, however i can only use ones on the 10.0.0.0 network and the linux box(192.168.0.1)
i also nat that connection so wireless98 box has internet access

now the weird part.
I load up a movie on wireless box it gets about 5 min in then wireless card craps out.nothing fixes it short of a reboot.
if i dont use it connection stays up indefinatly.
any activity at all and 5 min is the longest it lasts.

now the weirder part.
take the card out of linux box, put in xp box
works great WONT GO ABOVE 2 Mb/s
$@$#!$!@#@#%@%$#@#%$

build another computer put on board vga(old 133)
put isa 3com 3c509 and wireless card in.
put knoppix cd in as that was only thing worked*
boots up i have it dhcp 192.168.0.2
make wireless card 10.0.0.1
now its working fine.
*(i left out installing 7!!!! different distro's and having weird 5 min problem
except knoppix from cd.if i installed if to hard drive it broke something.)


so now i need help routing.
mandrake 9
eth0 is 192.168.0.1 and
eth1 is dhcped from comcast

knoppix
eth0 is 10.0.0.1(wireless card)
eth1 dhcps 192.168.0.2 from mandrake box

both boxes ipfilter NATting
so now wireless box has internet access again.it can ping anything on the internet and 10.0.0.1 and 192.168.0.1 but not any other 192.168.0.n on my net.
linux box can ping 10.0.0.1 but not 10.0.0.2
192.168.0.n computers can ping 10.0.0.1 but not 10.0.0.2

i tried
route add -net 192.168.0.0 netmask 255.255.255.0 gw 192.168.0.1
on knoppix box and
route add -net 10.0.0.0 netmask 255.0.0.0 gw 192.168.0.2
on mandrake box
and that didnt work...

anyone know how i make it so 10.0.0.2 can use windows file share on 192.168.0.100 having to pass through 192.168.0.2 and 192.168.0.1 on the way??

or a better addressing plan that would work?

or any help at all would be greatly appreciated

chris