Help - Search - Members - Calendar
Full Version: Several N00b Questions
Linuxhelp > Support > Technical Support
eastmanuk
Hey, I'm an avid Windows user, thought I'd give Linux a try, I'm using Fedora Core 4... Heres a few problems I've come up against;

1) When Grub boots, and Linux starts to boot, I get this;
Uncompressing Linux... OK, booting kernel
BUG: soft lockup detected on CPU#0
Any idea what this means? I'm using a Pentium 4 2.8GHz processor. It continues to boot fine after this, but it seems to wait around 10 seconds after that message...

2) Linux is installed on one of my IDE hard-drives; Windows XP is installed on my SATA hard-drive. The only way I can boot into Windows / Linux is to go into the BIOS and set which hard-drive to boot from. I've tried configuring Grub, but I'm a complete n00b here! I read something about hiding / unhiding partitions? I tried doing that, but it still freezes when it tries to boot... Heres my menu.lst
CODE
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,1)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/hdb
default=0
timeout=5
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu

title Fedora Core (2.6.11-1.1369_FC4smp)
root (hd0,1)
kernel /vmlinuz-2.6.11-1.1369_FC4smp ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.11-1.1369_FC4smp.img

title Fedora Core-up (2.6.11-1.1369_FC4)
root (hd0,1)
kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.11-1.1369_FC4.img

title Windows XP Home Edition
rootnoverify (hd1,0)
chainloader +1
makeactive


3) Wireless trouble... I have a Belkin USB wireless card, F5D7050. There are no drivers for this in Linux, so I had to install a program called DriverLoader. After registering this, I finally got it to say the wireless card was working, and I tried to enable it in the Network Device Manager, yet it wont assign an IP via DCHP. If I assign an IP address manually, then it says it connects fine, yet wont load any webpages. I've connected to webpages fine when I connected via the ethernet cable (which is connected directly to my wireless router).

4) The wireless program tells me to disable 4k stacks in the kernel, it kind of tells me what to do... Yet I don't understand! Can anyone explain to me how to do this, step-by-step?

5) Considering the DriverLoader program didn't seem to work (and I need to pay for it), I found another program; ndiswrapper. I follow the instructions to install it, I type make, then make install, and it all seems to install fine. The next thing it tells me to type is 'ndiswrapper -i filename.inf' yet it tells me that the command 'ndiswrapper' was not found.

OK, thats all for now... Any help would be greatly appreciated! Thanks!
Hemant
I will try to solve, few of your problems:

1. You have a HT CPU, so you should boot into Linux, using SMP kernel only. By the which kernel did you boot?
2.Whats the error you get when you press enter, after choosing Windows XP at the grub boot menu.
eastmanuk
Strangely enough, since posting the original article, I've had no problems with the soft lock-up thing. I have booted into Linux with the SMP kernel, as it was the default choice, and I don't know the difference between them smile.gif

I don't get an error when I click on the Windows option; it lists the commands, then just hangs.

And I've been playing about a bit more with the wireless stuff, I've now managed to install ndiswrapper properly, though it wont pick up my card now, could this be because driverloader is using it? How can I uninstall driverloader? In fact, how can I uninstall anything? Heh, I'm such a n00b when it comes to these things...

And theres still the question about 4k stacks option in the kernel... I've found a few guides on how to do it, though none make much sense to me; somehow, I'm meant to disable the option and recompile the kernel - it's like another language to me!
eastmanuk
Well, I've sorted the booting issue; heres the amended part of menu.lst;

CODE
title Windows XP Home Edition
rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +1


Still no luck with the wireless though... Can anyone tell me how to uninstall DriverLoader? Also, when attempting to find an IP address via DCHP, my router logs the attempts, it sees the request and sends the IP multiple times, it merely never ends up here! When manually assigning the IP, I checked the routers ARP table, which doesn't show up the IP. The system log doesn't see anything if I don't use DCHP; if I do, I just see it sending out an IP which never arrives... Anyone have any idea?

Edit: I have a feeling this is something to do with the 4k stacks option in the kernel... I'm going to have a play with it, see what I can do... Though I'm not too hopeful, if anyone could post a step-by-step guide of what to do, I'd be very grateful!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.