Help - Search - Members - Calendar
Full Version: Booting Problem Ever Seen
Linuxhelp > Support > Technical Support
balajimc
Hi all,

One system restarts after showing "checking hlt instruction..."
another system halts saying " Partition check hd0"

one started the system, and due to which both are of use
looking forward for any useful reply/suggestions from Linux/Unix masters.

Balaji
Termina
I'm a bit confused by your post, can you please re-submit and state your problem in a diffrent way? (I'm assuming english isn't your first language)

So you have two computers, with what Linux distro installed?

Did these two computers start acting up at the same time? Diffrent times? What caused this problem to happen?

Moving on;

If nothing else is wrong, then you should be able to get past the 'checking hlt instruction...' by using this with grub, on startup:

no-hlt

I'm unsure of what would be the problem with your other system. I suggest you grab a boot-disc or rescue CD and make sure your partitions are all intact on that machine.
balajimc
Hai,

Here goes problem description,

i have two PC (runned independently) both loaded with Redhat Linux as OS.
PC Description: CPU Type P III 500Mhz
640K SYSTEM RAM
255M Exyended RAM.

1. One PC is halted on saying Checking 'hlt' instruction.... when swithched ON and
2. The second PC also halts on saying
Partition check:
hda:

and tried with entering into text mode and giving
boot: no -hlt command which inturn gives no such image

pls solve my problem.

Looking for favourable reply.
Balaji.
Hemant
*sigh* , you should not use SMS English in the forums.

I guess, the support staff is still clueless about, what is the exact error?

Anway.. i guess, i can decipher your post for my staff collegues.

So.. he is saying the first PC freezes at "Checking halt instruction", when turned on.

The second one freezes at partition check.

Are you sure this is the error you got, when you booted in single user mode?

>>boot: no -hlt command which inturn gives no such image

can you just post the exact error?
Termina
QUOTE (balajimc @ Oct 19 2005, 12:48 AM)
Hai,

Here goes problem description,

i have two PC (runned independently) both loaded with Redhat Linux as OS.
PC Description: CPU Type P III 500Mhz
640K SYSTEM RAM
255M Exyended RAM.

1. One PC is halted on saying Checking 'hlt' instruction.... when swithched ON and
2. The second PC also halts on saying
Partition check:
hda:

and tried with entering into text mode and giving
boot: no -hlt command which inturn gives no such image

pls solve my problem.

Looking for favourable reply.
Balaji.

QUOTE
boot: no -hlt command which inturn gives no such image


"no-hlt" goes at the end of the "kernel" line in /boot/grub/grub.conf

You can do this when grub first loads (unsure how, I use lilo) as well.
balajimc
Thanks Termina, and Hemant sorry if used SMS english i will correct in next mails.

and the solution for the both problems are here "enter into text mode and give this command"
boot: linux no-hlt and press ENTER key, problem solved.

and went to google and came to know hlt is an instruction given to OS to halt the processor... no much idea about this, will definetly give to u all if i have any more information...


regards
Balaji.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.