Help - Search - Members - Calendar
Full Version: Having Problems Installing A Slax Based Distro
Linuxhelp > Support > Technical Support
JCoyne
I am new to linux and I am trying to install a SLAX based distro to hard drive. I have the distro copied to /hda1 according to the install instructions. When I boot the distro from CD, the distro mounts the /dev/hda1 to /mnt/hda1, I can see all the files are there but if I reboot without the CD it doesn't boot, just a flashing underscore. I can boot back up with the CD, use fdisk /dev/hda, then the p command and it tells me my partition is not bootable, I use the a command, then the w command and I get: errror 16: device or resource is busy. If I run fdisk again and use the p command, it now shows the drive as bootable, but when I restart (with the CD out) all I get is a flashing underscore again. Can someone point me in the right direction?
michaelk
Can you post a link to the intructions you are following?

Did you install lilo i.e. the bootloader?

linux does not care about the partition boot flag.
JCoyne
fdisk /dev/hda

mke2fs /dev/hda1

mkdir /mnt/hda1

mount /dev/hda1 /mnt/hda1

cp --preserve -R /{bin,dev,etc,home,lib,root,sbin,usr,var,opt,pentest,boot} /mnt/hda1

mkdir /mnt/whax/{proc,sys,tmp,mnt}

cp /boot/boot/vmlinuz /mnt/hda1/boot/

chroot /mnt/hda1

mount -t proc /proc proc

edit lilo.conf

execute lilo -v
JCoyne
I went back and re-ran lilo -v, it gives me the following error:

Fatal: Creat /boot/map~: Read-Only File System
michaelk
Did you edit lilo for read/write
http://slax.linux-live.org/forum/viewtopic...tall+hard+drive
Then run lilo
JCoyne
/etc/lilo.conf has the following

boot = /dev/hda
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda
label = linux
read-write
# Linux bootable partition config ends

I run lilo -v and it says:

Fatal: creat /boot/map~: Read-Only file system

I run lilo -M /dev/hda and it says:

Fatal: creat /boot/boot.0300: Read-only file system

I go back and double check /etc/lilo.conf and it is as above.

wacko.gif
JCoyne
Ok, I am an idiot. I was getting /etc/lilo.conf confused with /mnt/hda1/etc/lilo.conf

Once I chroot /mnt/hda1, then mount -t proc /proc proc, then edit /etc/lilo.conf (really /mnt/hda1/etc/lilo.conf) then lilo -v it wrote the bootloader.

Now here is my next problem:

After I boot the hard drive, lilo loads (thank god) and I can choose Linux and it begins to boot. Then it stops on

XFS: Bad magic number
XFS: SB validate failed
Kernel Panic - not syncing: VFS: unable to mount root fs on unknown-block(3,0)

Does this mean I formated with the wrong file system?
JCoyne
You can close this ticket.

I had root = /dev/hda in my /etc/lilo.conf when it should have been /dev/hda1
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.