Help - Search - Members - Calendar
Full Version: Monitor:unable To Probe
Linuxhelp > Support > Technical Support
beni
Hi! I am very new to Linux and this forum as well. I am presently using 98 and XP and have been trying to install Red Hat Linux 8.0. The problem is that the msg 'Monitor:Unable to probe' comes even if I pass the arg 'skipddc', for that matter even ' noprobe'. And then the system just hangs. I have tried umpteen times to install but it just go beyond that point, and I am really tired of resetting the computer everytime. PLease someone help me out!!!
My computer's configuration:
AMD Athlon XP 2000+
256MB DDR RAM
40 GB Samsung Puma
15" Samsung(Samtron)56V(I dont have Linux drivers for the monitor)
52X CDROM
cclavey
Did you pay for RedHat? If so...call tech support and bitch at them. If not, trying finding the specs for your monitior and installing it custom, if you can. Also, try checking with RedHat Hardware compatibility list here
chrisw
i did a search for your monitor and
nothing good came up...
i did though find some things about modifing
this file and that file...which didnt look good at all

so i am asumming that the monitor wont work properly
without major modifications to config files

i really hate to be the bearer of bad news...
hopefully i am wrong and you can find
so other better info but this is what i found
out for you so far
beni
Hello ppl,

Sorry I couldnt ckeck on in here earlier. Thnx for the effort. I forgot to mention that the install CDs came with Sams 'Red Hat Linux 8' authored by Bill Ball. I think something is wrong with my monitor and not with the cd. Anyway I have installed RHL 7.2 (official) and although installation was not a problem, it said the same thing during installation 'Monitor:Unable to probe'. And when I tried to configure X, everything went fine except when I gave 'startx' the screen went blank and I got a msg something like 'Unable to connect to server. Then I tried 'kdm' as well as 'gdm'. I get a graphical login, but the resolution is a lowsy 640X480(16 bit) with an even worse refresh rate. I tried changing the settings but nothing seems to work. In fact I couldnt figure out how to change it.
Well...can anyone help me out now??
sad.gif
chrisw
it is your monitor NOT the cd's
for some reason there has to be
some configuration changes needed
to get your monitor to work properly...

im sorry to say i dont know the configuration
changes...but the problem is your monitor
and NOT the cd's themselves
Hemant
Well i have the same monitor. (By way hard disk too).And i am using Redhat -7.3 without any problems and at least it is supported coz horizontal sync and vertical sync of my monitor were correctly determined during autoprobe.but unfortunately i didn't have a solution except try 7.3.

cool.gif and yes i have the same monitor
samtron 56v
Infact very popular in my country.
Corey
I didn't do much searching on your monitor, however, I will let you know what i did for my own.

I have a monitor that is not directly supported by linux, at least, I haven't seen it included in any linux distribution.

A quick look at the monitor manual shows that my monitor has the following settings:

HorizSync: 30-54
VertRefresh: 50-120
Max Res. 1024x768

Using these numbers taken from the manual, I can quickly and easily edit the /etc/X11/XF86Config-4 file that is install from setup to include these values and allow my monitor to work.

So, what we have is two options. First off, skip the X configuration from install (or at least set it up but don't test it, and tell your install program not to boot into X on bootup). The first option is to manually edit your /etc/X11/XF86Config-4 file as stated above, or, you can issue the command:

QUOTE
XFree86 -configure


Which will probe your monitor on the X level and create a default config file in your /root directory. You can open that file, edited as you please and mv it over to the /etc/X11 directory. This last option has always been my failsafe, and it almost never fails.
beni
Hello ppl! Thnx for all the help. Can do with a lil more of it.
Like I said I had been trying to RHL8. Last night I finally did it! Well it might interest you how I managed to do it. I had been running RHL 6.3. First of all I formatted my linux partitions and then started again from scratch. Right after anaconda gave the msg 'Monitor: Unable to probe' (and on previous attempts the system used to hang after that) I started pressing F2 like crazy thinking it might take me back to the first installation screen and lo behold, I get the next screen instead 'If you have bought RHL from RHL Inc, pliz register blah blah' and I was able to install without any hitch. But I was acreful not to configure X. After the install was over, configured X. But when I entered 'startx' the screen just went blank and no key combination could bring it back to CLI. I think it was a system hang again. I had to reset. Then the same thing happened in the next 20 attempts or so. I tried all different commands but got the same result everytime. In other words, X just simply wont start. I am really perplexed now. What could be so utterly wrong with my system. sad.gif
BTW where are you guys from?
/me is an Indian.
Corey
Well, there are any number of reasons why X won't start for you. Does your monitor actually switch off or go to standby mode? Have you checked the /etc/X11/XF86Config-4 file to make sure all the settings are right? This could also be a video problem, what video card do you have in the machine? I've had problems with the "nv" video driver for my nvidia GEforce2 that comes with XFree86, a quick download of the hardware accelerated drivers from nvidia fixed that problem.

To test to see if your system is locked solid, try hitting the num lock key, if the light can go on and off, then the system is probably not locked, but just hung on X which you can kill with Ctrl-Alt-Backspace. I've had to often go back to the console "blindly" by pressing Ctrl-Alt-F1, and logging back in as root and issuing the shutdown command all without seeing anything.

After issuing the command I have stated above (XFree86 -configure) try testing the configuration file it generates with the command it states afterwards (something like XFree86 -xf86config /root/XF86Config.new) and see if that starts your X server. It's a good place to start.
beni
The system hangs! This I can tell cuz I did the numlock thing and the LED just remained at whatever state it was in. Then even <ctrL><alt><del> doesnt work. I just have to reset the system.
Anyway, I think I will d/l the nvidia drivers from their site and try installing it. Will keep you guys posted on any new happenings/queries?? smile.gif
Hemant
I think your monitor should be samtron S/T/56E (something like this).
So if you are trying Redhat-8 then you can enter the sync range of your monitor manually. by command
#xfree86
then start x server in minimum resolution.(800x640).I would like to now about your video card also.
But samtron monitor is listed in the list of supported monitors.And your sync ranges confirm that i have got the same sync range of my monitor.

Another thing when i have replied to ur question earlier i haven't tried Redhat-8 but recently i have upgraded from 7.3 to 8.0.But currently i have my own problems.But your monitor is not supported by redhat-8.0 only if it is not too old.you can get exact model name of your monitor from windows device manager also.
beni
Hello yet again!!
Finally X is up and running. I d/led the NVIDIA kernel modules and display drivers as well as the motherboard drivers(unified). I didnt get things right in the first attempt cuz I installed the display drivers before the kernel module. So instead of trying to unistall and stuff, I just formatted the Linux partitions and installed everything from scratch. And this time around I installed everything in the correct order:-
1.kernel
2.diplay(GLX)
3.nforce(unified)
Now I am rocking on GUI linux smile.gif Just left with encoding my mp3s into ogg!!
Thnx to all who took time to post replies.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.